Temporarily disable xscreensaver ??


Page 1 of 2 12 LastLast
Results 1 to 15 of 17

Thread: Temporarily disable xscreensaver ??

  1. #1
    Join Date
    Nov 2002
    Location
    PA
    Posts
    56

    xscreensaver

    how do i disable xscreensaver temperarily? i want to watch a movie in mplayer and i keep getting interupted.
    One OS to rule them all,
    One OS to find them.
    One OS to call them all,
    And in salvation bind them.
    In the bright land of Linux,
    Where the hackers play.
    (J. Scott Thayer, with apologies to J.R.R.T.)

  2. #2
    Join Date
    Dec 1999
    Location
    Toronto
    Posts
    39,320
    KDE/Gnome?

    For KDE you could use the KDE Control Center to disable or see if there is a manpage for xscreensaver (man xscreensaver) or installed documentation that could possibly tell you how to temporarily disable.

    Anyone know a quick way to disable?
    SEARCH FIRST... ASK SECOND Read the JL 'Community Help Posting Guidelines' before posting in the forums.

    Precompiled Redhat NTFS Modules

    Linuxplanet Tutorials

    If Linux doesn't have the solution, you have the wrong problem. ... Please do not send me a PM asking for help...

    Please read the search suggestion thread in JL Ideas

  3. #3
    Join Date
    May 2003
    Location
    Peoria, IL
    Posts
    111
    I don't know if this would qualify as a quick way, but you could go to xscreensaver-demo and either choose "Disable Screen Saver" or you can just kill the xscreensaver daemon.
    Linux User #357977
    Host of the worst podcast on the web - Bored Gamers Radio

    "Are you saying that I have lower standards because I use 'I've Got Mail'?" Common Windows User

    "You've been one bad penguin." Bill Gates

    "It's not cheating if you don't get caught." Darl McBride

  4. #4
    Join Date
    Dec 1999
    Location
    Toronto
    Posts
    39,320
    Originally posted by Ryochan7
    Or you can just kill the xscreensaver daemon.
    I was thinking of that too, but then you would need to restart the daemon.

    Hopefully the xscreensaver docs have something on temporarily disabling.
    SEARCH FIRST... ASK SECOND Read the JL 'Community Help Posting Guidelines' before posting in the forums.

    Precompiled Redhat NTFS Modules

    Linuxplanet Tutorials

    If Linux doesn't have the solution, you have the wrong problem. ... Please do not send me a PM asking for help...

    Please read the search suggestion thread in JL Ideas

  5. #5
    Join Date
    Oct 2002
    Location
    Baton Rouge, Louisiana, USA
    Posts
    799
    *BUMP*

    I'm having this exact same problem--I have configured mplayer to my liking, but it gets interrupted by xscreensaver. Anyone have an answer?

    Thanks!
    Isaac Kuo, ICQ 29055726 or Yahoo mechdan

  6. #6
    Join Date
    Dec 1999
    Location
    Toronto
    Posts
    39,320
    Originally posted by IsaacKuo
    *BUMP*

    I'm having this exact same problem--I have configured mplayer to my liking, but it gets interrupted by xscreensaver. Anyone have an answer?

    Thanks!
    From the xscreensaver manpage (man xscreensaver)

    USING KDE (K DESKTOP ENVIRONMENT)
    I understand that KDE has invented their own wrapper around xscreensaver, that is inferior to xscreen_
    saver-demo(1) in any number of ways. I've never actually seen it, but I'm told that this is the way you
    disable it:

    1: Switch off KDE's screen saver.
    Open the ``Control Center'' and select the ``Look and Feel / Screensaver'' page. Turn off the
    ``Enable Screensaver'' checkbox.
    OR

    xscreensaver-command -exit
    SEARCH FIRST... ASK SECOND Read the JL 'Community Help Posting Guidelines' before posting in the forums.

    Precompiled Redhat NTFS Modules

    Linuxplanet Tutorials

    If Linux doesn't have the solution, you have the wrong problem. ... Please do not send me a PM asking for help...

    Please read the search suggestion thread in JL Ideas

  7. #7
    Join Date
    Oct 2002
    Location
    Baton Rouge, Louisiana, USA
    Posts
    799
    Thanks, I'm aware of ways to manually disabling the screensaver, but neither of those methods are temporary.

    I suppose I could make a simple script something like this:

    Code:
    #!/bin/sh
    xscreensaver -exit
    mplayer "$1"
    xscreensaver
    But this is slower and kludgy, and requires some tweaking all around (like disabling xscreensaver's splash screen).
    Isaac Kuo, ICQ 29055726 or Yahoo mechdan

  8. #8
    Join Date
    Oct 2003
    Location
    Vancouver, BC, Canada
    Posts
    215
    Originally posted by IsaacKuo
    But this is slower and kludgy, and requires some tweaking all around (like disabling xscreensaver's splash screen).
    xscreensaver -nosplash

  9. #9
    Join Date
    Dec 1999
    Location
    Toronto
    Posts
    39,320
    Originally posted by blargety
    xscreensaver -nosplash
    Also in the xscreensaver manpage.

    Does mplayer have a option that will disable screensavers?
    SEARCH FIRST... ASK SECOND Read the JL 'Community Help Posting Guidelines' before posting in the forums.

    Precompiled Redhat NTFS Modules

    Linuxplanet Tutorials

    If Linux doesn't have the solution, you have the wrong problem. ... Please do not send me a PM asking for help...

    Please read the search suggestion thread in JL Ideas

  10. #10
    Join Date
    Oct 2002
    Location
    Baton Rouge, Louisiana, USA
    Posts
    799
    If so, I haven't found it. gmplayer seems to have a line in ~/.mplayer/gui.conf which can supposedly deactivate xscreensaver, but I haven't been able to transplant this line successfully anywhere that mplayer would react to. I'm not even sure if it works with gmplayer, actually. There are a number of reasons I'm not using gmplayer, like it fails to come up in fullscreen properly initially (has blue border on the bottom; repeatedly toggling full-screen mode eventually fixes it).

    Anyway, I don't know how to get internet videos to work with the shell script I made. This isn't such a severe problem, because internet videos tend to be very short anyway. However, it does point out how inelegant the shell script solution is.
    Isaac Kuo, ICQ 29055726 or Yahoo mechdan

  11. #11
    Join Date
    Oct 2002
    Location
    Earth
    Posts
    1,613
    How about just setting it not to blank until after more minutes than the movie is.

    If the movie is 190 minutes. Set it to blank after 200 minutes.
    -------------
    Folding is Fun

    I thought I made a mistake once, but, of course, I was mistaken.

  12. #12
    Join Date
    Sep 2002
    Location
    Valencia, California
    Posts
    436
    guys guys guys... There's an option in mplayer to stop xscreensaver from activating! From the mplayer man page:
    Code:
           -stop-xscreensaver (X11 only)
                  Turns off xscreensaver at startup and turns it on again on exit.
    or you could always just do killall xscreensaver and then run xscreensaver again. Or move your mouse every 3 minutes.

  13. #13
    Join Date
    Oct 2002
    Location
    Baton Rouge, Louisiana, USA
    Posts
    799
    Thanks! Success! I somehow failed to see that -stop-xscreensaver option in the man pages. Based on a previous modification I made to get full screen playback, I edited ~/.mplayer/config to:
    Code:
    vo=xv,x11
    ao=arts,esd,oss
    fs=yes
    stop-xscreensaver=yes
    This works like a charm! Now, the videos play back at full screen and with the screensaver temporarily deactivated.

    Additionally, I am running KDE, and it wa necessary to go into KDE's Control Center-->Appearance & Themes-->Screen Saver configuration. I deactivated KDE's "start screensaver automatically" feature. If this feature is turned on, then the screen will blank to black when its timeout occurs.
    Isaac Kuo, ICQ 29055726 or Yahoo mechdan

  14. #14
    Join Date
    Apr 2003
    Location
    Buenos Aires, Argentina
    Posts
    4,221
    Originally posted by IsaacKuo

    Code:
    #!/bin/sh
    xscreensaver -exit
    mplayer "$1"
    xscreensaver
    Just so you know, it's xscreensaver-command -exit instead of xscreensaver -exit.
    djserz.com.ar
    "All the drugs in this world won't save you from yourself..."

  15. #15
    Join Date
    Dec 1999
    Location
    Toronto
    Posts
    39,320
    Originally posted by serz
    Just so you know, it's xscreensaver-command -exit instead of xscreensaver -exit.
    Exactly as I posted above.
    SEARCH FIRST... ASK SECOND Read the JL 'Community Help Posting Guidelines' before posting in the forums.

    Precompiled Redhat NTFS Modules

    Linuxplanet Tutorials

    If Linux doesn't have the solution, you have the wrong problem. ... Please do not send me a PM asking for help...

    Please read the search suggestion thread in JL Ideas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •