Hardware:Configuration:Floppy:SuSE - Page 2


Page 2 of 2 FirstFirst 12
Results 16 to 24 of 24

Thread: Hardware:Configuration:Floppy:SuSE

  1. #16
    Join Date
    Dec 1999
    Location
    Toronto
    Posts
    39,320
    Originally posted by Bold Jim

    As I understand it I have a floppy drive, so why can't I mount it,fedup and confused
    Because you are not using the correct mountpoint?

    For a dos/win formatted diskette that is inserted in the drive

    mount -t msdos /dev/fd0 /media/floppy

    For a ext2 (Linux) formatted diskette that is inserted in the drive.

    mount -t ext2 /dev/fd0 /media/floppy

    umount /media/floppy (before removing the diskette)
    SEARCH FIRST... ASK SECOND Read the JL 'Community Help Posting Guidelines' before posting in the forums.

    Precompiled Redhat NTFS Modules

    Linuxplanet Tutorials

    If Linux doesn't have the solution, you have the wrong problem. ... Please do not send me a PM asking for help...

    Please read the search suggestion thread in JL Ideas
    Share on Google+

  2. #17
    Join Date
    Jun 2003
    Location
    Stroud Gloucertershire England
    Posts
    17
    Tis me again
    I have been to bed for a hour, when I got up,
    I tried,mount -t auto /dev/fd0 /media/floppy, as root,
    this worked fine,now all I have to do get it to work in user.

    Never mind, I am off to Linux classes for the hard of thinking, next month,
    so hopefully I whon't bother you guys so much.

    Thanks for your help
    Boldjim
    Share on Google+

  3. #18
    Join Date
    Dec 1999
    Location
    Toronto
    Posts
    39,320
    Have a look through the mount manpage (man mount) for the user/users option you add to the floppy mountpoint in /etc/fstab.

    Searching the JL forums for 'floppy mount permission' or 'floppy mount user' should find other threads on the same topic.
    SEARCH FIRST... ASK SECOND Read the JL 'Community Help Posting Guidelines' before posting in the forums.

    Precompiled Redhat NTFS Modules

    Linuxplanet Tutorials

    If Linux doesn't have the solution, you have the wrong problem. ... Please do not send me a PM asking for help...

    Please read the search suggestion thread in JL Ideas
    Share on Google+

  4. #19
    Join Date
    Nov 2000
    Location
    /dev/3.14Pie/HowRandom
    Posts
    6,700
    A sample /etc/fstab entry which will allow non-root users to access the floppy:

    /dev/fd0 /media/floppy auto noauto,user 0 0


    The user option is what allows a non-root user to mount/unmount removable media such as floppies, CD-ROMs, Zip disks, etc. The "users" option is another slight variation; read the mount man page for a description of the difference betwen the two.

    A further breakdown on the options:

    auto - automatically detect the format of the floppy (msdos, ext2, etc.)

    noauto - do not automatically probe for and attempt to mount removable media at bootup. Since you probably won't usually have a floppy, CD-ROM, etc. inserted when you boot, this option speeds up the boot process a bit by bypassing the check for those disks.
    Share on Google+

  5. #20
    Join Date
    May 2002
    Posts
    1,249

    mount

    Even if bold jim entered the correct line in the /etc/fstab he still will not be able to mount the floppy by specifing a filesystem type. At least it doesn't work on my PC's.

    The user just uses the mount /media/floppy or mount /dev/fd0 ( in this case) command.
    Share on Google+

  6. #21
    Join Date
    Nov 2000
    Location
    /dev/3.14Pie/HowRandom
    Posts
    6,700

    Re: mount

    Originally posted by michaelk
    Even if bold jim entered the correct line in the /etc/fstab he still will not be able to mount the floppy by specifing a filesystem type. At least it doesn't work on my PC's.
    ?? It's always worked on my machines... as long as I use the correct syntax
    Share on Google+

  7. #22
    Join Date
    Jun 2003
    Location
    Stroud Gloucertershire England
    Posts
    17
    Yes Yes O Yes
    Success at last, I cam mount an icon on the desktop as user and read, & write to floppy.
    Sorry to be over the top but it has taken me three months(on and of)trying.

    Thank you all for all your help I have included my fstab so anyone, who does a shearch in the futcher can read it
    /dev/hda3 / reiserfs defaults 1 1
    /dev/hda1 /windows/C vfat users,gid=users,umask=0002,iocharset=iso8859-1,code=437 0 0
    /dev/hda2 swap swap pri=42 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0
    proc /proc proc defaults 0 0
    usbdevfs /proc/bus/usb usbdevfs noauto 0 0
    /dev/cdrom /media/cdrom auto ro,noauto,user,exec 0 0
    /dev/fd0 /media/floppy auto rwx,noauto,user,exec 0 0
    /dev/sr0 /media/sr0 auto ro,noauto,user,exec 0 0 #HOTPLUG B3Fu.Ps_7t2s11wC:D :D
    Boldjim
    Share on Google+

  8. #23
    Join Date
    Jul 2002
    Location
    Colorado USA
    Posts
    3,070
    I am glad you were able to mount your floppy drive

    and your welcome
    Some of my favorite links

    search engine's
    G4L & JL forum search
    one of the best Debian based distro's for new hardware
    registered Linux user # 288225
    Share on Google+

  9. #24
    Join Date
    Nov 2000
    Location
    /dev/3.14Pie/HowRandom
    Posts
    6,700
    [SOLVED]

    [searching keywords]
    /dev/fd0 mount SuSe fstab floppy user
    Share on Google+

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •