Problems installing FTP on Redhat 9


Results 1 to 9 of 9

Thread: Problems installing FTP on Redhat 9

  1. #1
    Join Date
    Apr 2004
    Posts
    6

    Problems installing FTP on Redhat 9

    I am trying to get my FTP server working with my Redhat 9 install. This is a basic install, using everything that came with the CDs. Nothing else has been done except a simple IP Forwarding script.


    I have checked the service is on, and try to log in from the same machine and get the following:

    [shadow@Boothby etc]$ ftp localhost
    Connected to Boothby.
    220 Boothby FTP server (Version 5.60) ready.
    334 Using authentication type GSSAPI; ADAT must follow
    GSSAPI accepted as authentication type
    GSSAPI error major: Miscellaneous failure
    GSSAPI error minor: No credentials cache found
    GSSAPI error: initializing context
    GSSAPI authentication failed
    334 Using authentication type KERBEROS_V4; ADAT must follow
    KERBEROS_V4 accepted as authentication type
    Kerberos V4 krb_mk_req failed: You have no tickets cached
    Name (localhost:shadow): shadow
    530 Must perform authentication before identifying USER.
    Login failed.
    Remote system type is UNIX.
    Using binary mode to transfer files.
    ftp>



    Any help in telling me what is wrong, and how to fix would be apreciated.

  2. #2
    Join Date
    Dec 1999
    Location
    Toronto
    Posts
    39,329
    Moved to the Software forum since Installation is meant for distro install issues.
    SEARCH FIRST... ASK SECOND Read the JL 'Community Help Posting Guidelines' before posting in the forums.

    Precompiled Redhat NTFS Modules

    Linuxplanet Tutorials

    If Linux doesn't have the solution, you have the wrong problem. ... Please do not send me a PM asking for help...

    Please read the search suggestion thread in JL Ideas

  3. #3
    Join Date
    Apr 2004
    Posts
    6
    Thanks Took a 50/50 on Install / Software forum..

  4. #4
    Join Date
    Dec 1999
    Location
    Toronto
    Posts
    39,329
    I did a G4L search for

    ftp "530 Must perform authentication before identifying USER"

    and these are a few of the possible solutions I found (including a link).

    > 220 localhost.localdomain FTP server (Version 5.60) ready.
    > Name (1.1.1.1:usrid): userid
    > 530 Must perform authentication before identifying USER.
    > ftp: Login failed.

    I have seen this before (but not on Red Hat Linux 9.0). I believe you are
    using a Kerborized FTP.

    Check your xinetd configs, and make sure you are using the regular FTP (if
    that is what you want).

    Try running ftp with the '-d' flag to see what it's sending
    too for grins, and check your logs to see if there are any error
    messages. Also, be sure that the user's shell is in /etc/shells,
    or it can't ftp.

    http://www.linuxforum.com/forums/ind...howtopic=11939

    > When I try to log into my FTP, it said
    >
    > 530 Must perform authentication before identifying USER.
    >
    > and refused me to log in.
    >
    > Would anyone here can help?

    Shot in the dark: you've enabled the gssftp server included in the
    krb5-workstation package, which by default is configured to only allow
    access to users who can authenticate using gssapi.

    If this is the case, run "ntsysv" as root, deselect "gssftp", select
    "wu-ftpd", and run "/sbin/service xinetd reload" to fix it.
    Also ensure the user is in /etc/ftpusers.
    SEARCH FIRST... ASK SECOND Read the JL 'Community Help Posting Guidelines' before posting in the forums.

    Precompiled Redhat NTFS Modules

    Linuxplanet Tutorials

    If Linux doesn't have the solution, you have the wrong problem. ... Please do not send me a PM asking for help...

    Please read the search suggestion thread in JL Ideas

  5. #5
    Join Date
    Apr 2004
    Posts
    6
    I remember using wu-ftpd on previous versions of RH... infact when I started to try and figure this out I automatically went looking for it... but couldnt find anything for it.

    Will try what you said... sounds good.

    Thanks.

  6. #6
    Join Date
    Apr 2004
    Posts
    6
    Found my problem... I think... no wu-ftpd service available.

    I checked /etc/xinetd.d/ and there is notthing listed for wu-ftpd.

    I have something called vsftpd - I enabled that and was just refused a connection.

  7. #7
    Join Date
    Apr 2004
    Posts
    6
    I have spent the evening playing with the settings on vsftpd - and seem to now have a working ftp server...


    well I think


    Thanks for the suggestions. Will check back to see anyone has any constructive comments about this

  8. #8
    Join Date
    Dec 1999
    Location
    Toronto
    Posts
    39,329
    Originally posted by Kelton
    Seem to now have a working ftp server...

    Will check back to see anyone has any constructive comments about this
    Is it now working or do you require additional assistance?

    Have you tried the Redhat online documentation to see if they have anything on setting up and configuring the included ftp server(s)?

    https://www.redhat.com/support/resou...owto/rhl9.html
    SEARCH FIRST... ASK SECOND Read the JL 'Community Help Posting Guidelines' before posting in the forums.

    Precompiled Redhat NTFS Modules

    Linuxplanet Tutorials

    If Linux doesn't have the solution, you have the wrong problem. ... Please do not send me a PM asking for help...

    Please read the search suggestion thread in JL Ideas

  9. #9
    Join Date
    Apr 2004
    Posts
    6
    Yes thanks.

    I just ftp'ed over my test web site on my Windows box to it - a few hundred meg without problems!


    That's probably the limit of what I will be using it for, It's behind a firewall and I won't be opening it up for public use.

    Thanks

    Kel.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •