How can I hide the mouse pointer?


Page 1 of 2 12 LastLast
Results 1 to 15 of 16

Thread: How can I hide the mouse pointer?

  1. #1
    Join Date
    Apr 2004
    Posts
    7

    How can I hide the mouse pointer?

    I am a newbie to Linux, so I apologize in advance for what may be an easy or ignorabt question.

    I am running "chbg" as a screensaver on my Mandrake Linux server and the mouse pointer is prominently displayed in the middle of my screensaver pictures.

    Does anyone know how to hide or kill the mouse pointer?

    Since this system has no keyboard or mouse so I don't mind killing the process supporting the mouse if that is a possible option.

    Thanks for your help.......

  2. #2
    Join Date
    Dec 1999
    Location
    Toronto
    Posts
    39,329

    Re: How can I hide the mouse pointer?

    Originally posted by stowheliman

    Since this system has no keyboard or mouse so I don't mind killing the process supporting the mouse if that is a possible option.
    Is this running stickly as a server (apache, mail etc.)? If it is, you really do not need to have X/KDE/Gnome running.

    If not, you could try commenting out the InputDevice section for your mouse in /etc/X11/XF86Config or XF86Config-4, make sure you have

    Code:
    Section "ServerFlags"
         Option        "AllowMouseOpenFail"
    EndSection
    in the ServerFlags section and then restart X.

    Any options in the screensavers to hide the mouse pointer?
    SEARCH FIRST... ASK SECOND Read the JL 'Community Help Posting Guidelines' before posting in the forums.

    Precompiled Redhat NTFS Modules

    Linuxplanet Tutorials

    If Linux doesn't have the solution, you have the wrong problem. ... Please do not send me a PM asking for help...

    Please read the search suggestion thread in JL Ideas

  3. #3
    Join Date
    Apr 2004
    Posts
    7
    Thanks for your reply mdwatts.

    This server requires KDE to be running. So its more than just a regular server that might be running Apache. Even though it has KDE running, it has no mouse or keyboard attached since it's physically hanging on the wall (or least the flat panel monitor is on the wall; the computer is hidden inside the wall) and therefore no mouse or keyboard should be attached. Its meant to look like a picture frame. The monitor is running a screensaver so the flat panel monitor is actually the "digital frame".

    As you probably know, when I comment out the lines you suggest, KDE does not load which means the KDE screensaver (chbg) will not start. Also, there are no options in "chbg" to hide the mouse pointer.

    Even if the mouse pointers position was changed to somewhere else on the screen (other than the middle) I'd be happy.

    Any more ideas on howto hide or kill the mouse pointer yet keep KDE up?

  4. #4
    Join Date
    Aug 2002
    Location
    Cayman Islands
    Posts
    681
    Just out of curiosity, what server is this that requires KDE?
    Scotty: Captain, we din' can reference it!
    Kirk: Analysis, Mr. Spock?
    Spock: Captain, it doesn't appear in the symbol table.
    Kirk: Then it's of external origin?
    Spock: Affirmative.
    Kirk: Mr. Sulu, go to pass two.
    Sulu: Aye aye, sir, going to pass two.

  5. #5
    Join Date
    Jan 2003
    Posts
    979
    what on earth does it need KDE???

  6. #6
    Join Date
    Apr 2004
    Posts
    7
    I guess I'm using the word "server" loosely. This linux server is serving up digital pictures. I am using "chbg" to display the digital images which requires a graphical environment such as KDE. But if there are other alternatives, I'm certainly open.

    The solution I'm working on right now works great with one minor problem. The fact that the mouse pinter is prominently displayed in the middle of the screen as the screensaver displays my digital pictures.

    So if there is anyway to remove or hide the mouse pointer from the display, or even move the pointer to a corner of the screen, I'd be a happy camper.

  7. #7
    Join Date
    Aug 1999
    Location
    Juneau, AK USA
    Posts
    779
    You could use a different window-manager to display your screensaver. IIRC IceWM didn't leave any mouse pointer hanging out when I used to use a screensaver.
    We'll get thisright yet!

  8. #8
    Join Date
    Mar 2003
    Location
    Augusta, GA
    Posts
    5,461
    Take a look at this article,

    xset
    and
    Using xloadimage
    You can cut out using KDE and use xscreensaver to cycle through the graphics.
    And you may be able to eliminate the cursor using, "# xsetroot -cursor_name (leave blank)"
    __________________________________________________ _______________________________________
    Bigboogie on boogienights.net:
    Ammo case
    Asus 8N32 SLI MB
    AMD Athlon x2 3800+
    2 GB Patriot Signature 400 DDR
    160 GB Hitachi 7200 IDE
    2 x-250 Seagate SATA2
    EVGA Nvidia 7900GT
    Dell 2007WFP
    Logitech 5.1 speakers
    Logitech MX1000 mouse
    Dell USB keyboard
    NEC 3500 DVD-RW
    Benq 1655 DVD-RW



    (God bless tax refunds)

  9. #9
    Join Date
    Feb 2004
    Location
    The Matrix
    Posts
    466
    Hmmm.... I just wanted to say ratpoison, but I tested it and it does have a pointer in normal use (no guis open). Why can't you just momentarily stick a mouse in and move it? When configuring X in a graphical environment you can move the mouse with keybindings - maybe it remembers the position?
    I'd look for a different screensaver and see if that does remove the pointer. Maybe you could customize the pointer into something totally transparent? Never made my own pointers though - so can't really help ya with that.
    HTH
    Sam
    I hated going to weddings. All the grandmas would poke me saying "You're next". They stopped that when I started doing it to them at funerals.
    OpenBox 3 | FVWM Crystal | FreeBSD | Linux Apps | Bash scripting | Perl | Python | My Site

  10. #10
    Join Date
    Apr 2004
    Posts
    7
    Thanks for the posts, you've given me something to try this evening. I'd really like to get chbg working instead of abandoning it in favor of another screensaver.

    While I can attach a mouse, I'd prefer not to have a mouse hanging from the wall since this is "digital frame" physically hanging on a wall.

    Thanks......

  11. #11
    Join Date
    Mar 2003
    Location
    Augusta, GA
    Posts
    5,461
    If you show Salvador Dali, or some of the other surrealists, a dead mouse hanging on the wall would probably blend in.
    __________________________________________________ _______________________________________
    Bigboogie on boogienights.net:
    Ammo case
    Asus 8N32 SLI MB
    AMD Athlon x2 3800+
    2 GB Patriot Signature 400 DDR
    160 GB Hitachi 7200 IDE
    2 x-250 Seagate SATA2
    EVGA Nvidia 7900GT
    Dell 2007WFP
    Logitech 5.1 speakers
    Logitech MX1000 mouse
    Dell USB keyboard
    NEC 3500 DVD-RW
    Benq 1655 DVD-RW



    (God bless tax refunds)

  12. #12
    Join Date
    Jan 2003
    Posts
    979
    oh, yes. just go to kde-look.org, get a pretty cursor and then edit the image to make it completely transparent.

  13. #13
    Join Date
    Apr 2004
    Posts
    7
    Well I tried several options this evening including xsetroot and I had no luck. I still have a mouse pointer prominently displayed in the middle of the pictures.

    Perhaps I've found a problem Linux cannot resolve....

  14. #14
    Join Date
    Jan 2003
    Posts
    979
    bah, linux is the kernel, it has no GUI. if anyone is to be blamed, its CFree86 for their real slowness. hopefully X.org will be more faster in dev.

    anyway, the solution to your problem is here, just make your own transparent cursor:
    http://www.kde-look.org/content/show.php?content=11428

  15. #15
    Join Date
    Oct 2002
    Location
    Baton Rouge, Louisiana, USA
    Posts
    799
    Hey, it sounds to me like you're not using chbg as a screensaver, but as a background changer. Thus, the mouse pointer is SUPPOSED to be visible. By default, that's what chbg does, anyway. I haven't used it as a screensaver; I use it as a background changer in PekWM.

    KDE has its own funny screensaver wrapper which may be part of the problem. Maybe KDE is simply starting up chbg as a background changer (i.e. setting root display background), rather than as a screensaver.

    Anyway, I suggest deactivating KDE's screensaver, and possibly not using KDE at all. Then check chbg's documentation for how to use it as a screensaver rather than a background changer.

    Alternatively, you could use xscreensaver. It's designed more for doing lots of cool looking screensavers, but it could be used for just a slideshow if you play with it enough. There are a number of screensavers included which can take the source image from an image collection.
    Isaac Kuo, ICQ 29055726 or Yahoo mechdan

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •