ALSA problem after kernel upgrade


Results 1 to 7 of 7

Thread: ALSA problem after kernel upgrade

  1. #1
    Join Date
    Sep 2004
    Location
    /home/
    Posts
    1,204

    [solved]ALSA problem after kernel upgrade

    i just compiled t 2.6.9(thanks to those who helped with that)
    im running slackware 10.0
    my creative 5.1 worked in 2.4.26 kernel find

    compiled kernel with mixer/alsa support
    reinstalled alsa drivers/alsa-utils.alsa-lib with package installer

    when i run alsaconf i get "no supported cards found"

    what am i missing?


    soule
    Last edited by soulestream; 12-20-2004 at 12:46 AM.
    Anarchism is founded on the observation that since few men are wise enough to rule themselves, even fewer are wise enough to rule others. - Edward Abbey

    IRC #linuxn00b

    Support your Distro.
    Slackware Store
    Archlinux Schwag

  2. #2
    Join Date
    Jan 2004
    Location
    Dallas, Texas
    Posts
    648
    Don't build alsa into the kernel at all. Install the base OSS package and drivers for your card in OSS. Alsa seems to need that when you install the modules. Then download the source for alsa-driver, alsa-lib, alsa-oss, and alsa-utils. Install them genericly from source and use checkinstall if you want (normally I use make install for alsa to be safe). Then run alsaconf. I had the same problem you do and this was the only way I found to get around it.

    EDIT: I think I missread your post (it's late here). If the cards not found I would try `modprobe emu10k1` or `modprobe snd-emu10k1` before trying the above.
    Last edited by Gogeta_44; 12-18-2004 at 01:26 AM.
    Desktop: Slackware 12, linux-2.6.23, GNOME;
    Firewall: OpenBSD
    Cube anyone?
    Deliantra: an amazing mmo, realtime nethack.
    Don't make the same mistakes I did as a new user: Read the Posting Guidelines or face being banned! [/color]

  3. #3
    Join Date
    Mar 2002
    Location
    Alton, Illinois, USA
    Posts
    1,126
    All I did was compile the kernel with the proper sound modules for my card...see if the proepr module is loaded.
    "You are not beaten until you admit it." --George S. Patton

    "Reading and learning, it's what linux users do"
    "Double clicking" doesn't work on Linux

    G4L | ZSH - The Z Shell

    Apple OS X, FreeBSD, and Smoothwall

  4. #4
    Join Date
    Apr 2003
    Location
    UK
    Posts
    1,181
    Did you check the options under alsa for your soundcard in the kernel? If you did, did you compile it as modules or built-in? I built the drivers into the kernel when I did it and it has worked fine both on Slackware (2.6.7) and Gentoo (2.6.8).

  5. #5
    Join Date
    Sep 2004
    Location
    /home/
    Posts
    1,204
    ok i recompiled alsa into kernel with my soundcard. no dice.

    so i recompiled with my device and alsa as module.

    my mixer worked(kinda)

    did modprobe
    found card.

    ran alsaconf

    found card and configured it.

    i still got no sound.

    made sure every setting that it sould let me raise it did and nothing is on mute. i have no sound for prgrams running or line in. (i cant even find the line in setting)

    any ideas.

    edit. i had the alsa drivers, oss etc installed twice. i removed them completely. and i am going to reinstall. ill repost if that doesnt work



    soule
    Last edited by soulestream; 12-19-2004 at 03:22 PM.
    Anarchism is founded on the observation that since few men are wise enough to rule themselves, even fewer are wise enough to rule others. - Edward Abbey

    IRC #linuxn00b

    Support your Distro.
    Slackware Store
    Archlinux Schwag

  6. #6
    Join Date
    Sep 2004
    Location
    /home/
    Posts
    1,204
    okay i reinstalled alsautils,oss,drivers,and libs and still got no sound any ideas?



    edit: uninstalled oss, now i have sound, yeah!

    but i still have no sound/control for input. this is very important cause my mulitmedia pc hooks to this one for sound.


    reedit okay got it working. in alsamixer and a mixer the input didnt show it was muted, installed gnome-alasmixer and i found the mute checked on a few items.

    soule
    Last edited by soulestream; 12-20-2004 at 12:48 AM.
    Anarchism is founded on the observation that since few men are wise enough to rule themselves, even fewer are wise enough to rule others. - Edward Abbey

    IRC #linuxn00b

    Support your Distro.
    Slackware Store
    Archlinux Schwag

  7. #7
    Join Date
    Feb 2003
    Location
    Arkansas, CSA
    Posts
    886
    I always double check alsamixer to make sure that the sound ain't muted (or set to zero). BTW, I have Sound and ALSA compiled as a module in my kernel. That way you can just do lsmod to make sure it's there . Strange that alsaconf didn't set alsamixer to a level that would be "hearable".

    Also, I see that you are using Gnome. Click on the "start foot", then Applications and Preferences (I think) and then Advanced Settings. Open Multimedia Selector (again I think that's what it's called) and make sure that you aren't actually using OSS instead of ALSA.

    Just a thought,
    MMYoung
    In the 60's people took LSD to make the world weird. Now the world is weird and people take Prozac to make it normal.

    Slackware 11.0 - Dropline GNOME 2.16.1 - kernel 2.6.18
    openSUSE 10.2 with Xgl/compiz/beryl
    Windows XP - kernel klink
    Buy Slack
    Dropline GNOME

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •