The folder contents could not be displayed


Results 1 to 9 of 9

Thread: The folder contents could not be displayed

  1. #1
    Join Date
    Mar 2003
    Location
    Guadalajara, Mexico
    Posts
    6

    Unhappy The folder contents could not be displayed

    Hi
    I'm using Fedora C3..i setup samba already..i can access from my windows to the Linux box without problems..
    My problem is to access from Linux to windows shares..Windows 2003 Server
    I can see the workgroup, even the computers but no the shares.
    The error i get is: The folder contents could not be displayed in every windows pc..
    any ideas?
    Thanks

  2. #2
    Join Date
    Jun 2001
    Posts
    107
    Have you tried using the command line to mount the share?

    smbmount //<hostname>/<share> /mnt/<mntpoint> -o username=<username>,password=<password>

  3. #3
    Join Date
    Mar 2003
    Location
    Guadalajara, Mexico
    Posts
    6
    Thanks for the reply..i applied your suggestion and now appears this:

    cli_negprot: SMB signing is mandatory and we have disabled it.
    3815: protocol negotiation failed
    SMB connection failed

    help..

  4. #4
    Join Date
    Feb 2003
    Location
    Mauritius
    Posts
    1,151
    Feel free to PM me for help

    Using PCLinuxos 2007 on my laptop and 2009 on my Desktop and proud of it!

    Desktop:
    AMD Phenom II x2 545 3GB DDR2 RAM 500GB SATA,250GB SATA, 250GB IDE, ATI Radeon HD 4870 512 DDR3
    Laptop:
    Intel Core 2 Duo T7500 (2.2) 2GB RAM, 160GB Sata HDD, nVidia 8600GM 512MB

    Please come back and tell us if your problem is solved, it may help others, and stop us from wondering what happened.

  5. #5
    Join Date
    Aug 2001
    Location
    Somewhere, Texas
    Posts
    9,628
    Originally posted by r46792
    Thanks for the reply..i applied your suggestion and now appears this:

    cli_negprot: SMB signing is mandatory and we have disabled it.
    3815: protocol negotiation failed
    SMB connection failed
    smbfs does not support SMB signing
    Windows Server 2003 is not your 'normal' smb share, look into CIFS
    http://www.samba.org/samba/Linux_CIFS_client.html

    LinNeighborhood is a great GUI, but it won't work until you solve the problem

  6. #6
    Join Date
    Jun 2001
    Posts
    107
    Originally posted by r46792
    Thanks for the reply..i applied your suggestion and now appears this:

    cli_negprot: SMB signing is mandatory and we have disabled it.
    3815: protocol negotiation failed
    SMB connection failed

    help..
    Try disabling SMB signing on the Windows 2003 Server:

    Under Local Security Policy:
    Local Policies --> Security Options
    Disable "Digitally Sign Packets" (SMB Signing)

  7. #7
    Join Date
    Mar 2003
    Location
    Guadalajara, Mexico
    Posts
    6

    Smile

    Thanks guys ...disabling the digital sign solved the problem...i owe one
    Btw: It's a little tricky under Active Directory Domain Controller because it has 2 Local Security Policies, one for the DC and one for the Domain..The one that works is the DC..

  8. #8
    Join Date
    Jun 2001
    Posts
    107
    Originally posted by r46792
    Thanks guys ...disabling the digital sign solved the problem...i owe one
    Btw: It's a little tricky under Active Directory Domain Controller because it has 2 Local Security Policies, one for the DC and one for the Domain..The one that works is the DC..
    Thanks for the tip, glad its working!

  9. #9
    Join Date
    Sep 2001
    Location
    Portugal
    Posts
    711
    Hi, im having the same problem, i have updated(security patches) Windows 2003 Server , and i used to sign in the Win2003 Shares, but know he returns
    cli_negprot: SMB signing is mandatory and we have disable it

    I have tryied to find
    Under Local Security Policy:
    Local Policies --> Security Options
    Disable "Digitally Sign Packets" (SMB Signing)

    but there is nothing "Digitally Sign Packets).

    I have gone "Start-> Programs->Administrative Tools-> Domain Controler Security Policy.

    There i have found
    Domain Member: Digitally Encrypt or sign secure channel data (allways) --> Enable.

    I have tried to disable, but the error remains

    Must i reboot the system, or this is nothing to have what im looking for?

    Thanks
    M3rlin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •