Audigy 2 ZS in Ubuntu

Results 1 to 5 of 5

Thread: Audigy 2 ZS in Ubuntu

  1. #1
    Join Date
    Oct 2003

    Audigy 2 ZS in Ubuntu

    I recently installed ubuntu and I love it, the only thing that's keeping me from running it almost full time is audio. I've got an Audigy 2 ZS sound card and Alsa seems to recognize it. In the Volume Control panel it shows 4 devices, two OSS ones, and two ALSA ones. One alsa on is intel, which I assume is my onboard sound, which I disabled, so I'm not sure why it picked it up, and the other ALSA one is the Audigy 2. I've got CD audio just fine, but when I try to play files from the HDD I get nothing. It shows them playing, but no sound. I've unmuted everything, and even tried plugging the speakers into the onboard audio to see if it's going through there. I'm a bit new to setting up sound devices on linux, so any help would be greatly appreciated.


  2. #2
    Join Date
    Dec 2002
    West Virgina, USA, North America, Earth, Western Spiral Arm, Milkyway Galaxy, The Universe As We Know It
    Double check that your onboard soundcard is disabled. if it really is turned off at the CMOS level, it shouldn't be showing up at all. Then try removing the intel modual.
    In the beginning the universe was created. This has made a lot of people angry and has widely been regarded as a bad move... --Douglas Adams

  3. #3
    Join Date
    Dec 2002
    I am guessing that you are using XMMS to play mp3/ogg files. If you are then look at the preferences in XMMS and make sure you are using the right output plugin. XMMS should work if it is set to alsa or OSS as long as oss emulation is enabled through alsa. I also have an audigy2 zs and had to fiddle with the output of XMMS on my slackware install.

    If you are actually getting an error while trying to access /dev/dsp, then it's a permissions issue. A simple chmod 666 /dev/dsp will fix that.
    Check out my ebay auction for my signature space on JLC.

    Hey if people can sell advertising space on thier bodies, I figure I can make $.02 on my signature space.

  4. #4
    Join Date
    Dec 2003

    Try Adjusting Volume Levels with Alsamixer

    Hi spacemonkey1036,

    Please try this.

    Open up a terminal window, and type the command:

    Make sure that the volume levels are turned up and that the Master channels are not muted.

    Are you certain that the emu10k1 driver(s) is loaded? Please try the 'lsmod' command in a terminal. You should see something similar to this listed.
    ac97_codec 21900 0
    snd_seq_midi 12704 0
    snd_emu10k1_synth 11520 0
    snd_emux_synth 41088 1 snd_emu10k1_synth
    snd_seq_virmidi 11648 1 snd_emux_synth
    snd_seq_midi_event 11904 3 snd_seq_oss,snd_seq_midi,snd_seq_virmidi
    snd_seq_midi_emul 11392 1 snd_emux_synth
    thermal 16648 0
    snd_seq 61584 9 snd_seq_oss,snd_seq_midi,snd_emux_synth,snd_seq_vi rmidi,snd_seq_midi_event,snd_seq_midi_emul
    processor 21312 1 thermal
    fan 8196 0
    button 10384 0
    battery 12804 0
    snd_emu10k1 99240 5 snd_emu10k1_synth
    snd_rawmidi 29248 3 snd_seq_midi,snd_seq_virmidi,snd_emu10k1
    snd_seq_device 13068 7 snd_seq_oss,snd_seq_midi,snd_emu10k1_synth,snd_emu x_synth,snd_seq,snd_emu10k1,snd_rawmidi
    snd_ac97_codec 75768 1 snd_emu10k1
    ac 8964 0
    snd_pcm 96772 3 snd_pcm_oss,snd_emu10k1,snd_ac97_codec
    snd_timer 29444 3 snd_seq,snd_emu10k1,snd_pcm
    snd_page_alloc 13960 2 snd_emu10k1,snd_pcm
    snd_util_mem 8832 2 snd_emux_synth,snd_emu10k1
    snd_hwdep 13984 2 snd_emux_synth,snd_emu10k1

    If emu10k1 isn't listed, then you'll need to apprise us of which distribution of Linux you're using. Once we know, we can go from there, if need be. I hope my ramblings at least help to get you going in the right direction.

  5. #5
    Join Date
    Mar 2005

    sound problems

    sometimes the problem with new sb cards is that the optical audio is enabled by default.. there is an option in kmix under "switches" that will turn this off (or on)..
    other mixers have it too.. but you'll have to look for it..
    Not sure if it helps, but it's happened to me lots.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts