MPlayer mp4 problem fixed on Debian Lenny.


Results 1 to 1 of 1

Thread: MPlayer mp4 problem fixed on Debian Lenny.

  1. #1
    Join Date
    Mar 2003
    Location
    UK
    Posts
    621

    MPlayer mp4 problem fixed on Debian Lenny.

    Using Debian Lenny 5 backport up-to-date. 2.6.30-bpo.1-amd64 .

    MPlayer would not play *.mp4 files satisfactorily. They paused every third of a second or so, then ran on, paused then ran on; both sound and vision. Sort of stuttered. This also happened with the browser mplayer plugin.

    Slightly elaborate fix:

    Uninstall mplayer, apt-get remove mplayer

    Then get hold of the latest mplayer: svn checkout svn://svn.mplayerhq.hu/mplayer/trunk mplayer

    Install libasound2-dev to give alsa.
    Then install # apt-get install libxv-dev.
    then:
    # apt-get install libvdpau-dev

    Then compile mplayer, this is for Debian, in the mplayer directory created by svn; subversion needs to have been installed:
    # DEB_BUILD_OPTIONS="--enable-runtime-cpudetection" debian/rules
    binary

    No idea if --enable..... is a good idea - the thing is just a method of giving options to .configure, e.g. --prefix=/home/fergie

    Then install the *.deb file that has been created in the home directory usually.

    Err, that's it.
    Last edited by lugoteehalt; 06-10-2010 at 09:50 PM.
    MI6, Offensive Information, Hackers, Encryption, UFO, AOL, Infowar, Bubba, benelux, Ufologico Nazionale, domestic disruption, 15kg, DUVDEVAN, debugging, Bluebird, Ionosphere, Keyhole, NABS, Kilderkin, Artichoke, Badger, spookwords, EuroFed, SP4, Crypto AG a few, alleged, Echelon keywords. Please add some to your email signature. Full list: http://www.serendipity.li/cia/bz1.html
    http://www.nosoftwarepatents.com/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •