On my 64 bits HardyHeron I could not get Eclipse started and aside of that I got Eclipse 3.2 instead of the latest version called Ganymede.

The solution to get it done is this:
1. deinstall everything what has to do with gij using Synaptic.
2. install sun jdk
3. download eclipse ganymede
4. unpack it and it will work.

With kind regards,