OpenOffice Base "driver class org.hsqldb.jdbcDriver"


Results 1 to 6 of 6

Thread: OpenOffice Base "driver class org.hsqldb.jdbcDriver"

  1. #1
    Join Date
    May 2003
    Location
    New Jersey
    Posts
    1,258

    OpenOffice Base "driver class org.hsqldb.jdbcDriver"

    Hello JL! It's been quite a while for me to write on here (I'm lousy at forums and things anymore) but I hope all is well.

    Anyways, here's an issue I have that I can't seem to find a lot of info on. I'm running OpenOffice3 Beta 2 right now (which might be the issue in itself) and more particularly, I'm trying to run Base for generating a real simple application. After creating the DB and attempting to do any work on it, I get the follow error:

    "The driver class 'driver class org.hsqldb.jdbcDriver' could not be load (additional driver class path: file:///user/share/java/hsqldb.jar vnd.sun.star.expand: $OOO_BASE_DIR/programs/classes/sdbc_hsqldb.jar)"

    I'm guessing it could be a PATH issue. I made sure to set that variable OOO_BASE_DIR to what should be the appropriate place, but no go still. Any thoughts?
    The Swain

    dswain

  2. #2
    Join Date
    Apr 2001
    Location
    SF Bay Area, CA
    Posts
    14,947
    Do you have an hsqldb.jar or sdbc_hsqldb.jar file around anywhere? If so, where is it? Copying it into OOO_BASE_DIR/programs/classes/ might help, but if it's already in a .../programs/classes/ path, then I'd try setting OOO_BASE_DIR to that directory instead. Or set CLASSPATH perhaps...

  3. #3
    Join Date
    May 2003
    Location
    New Jersey
    Posts
    1,258
    Alright! Managed to get it. I tried your advice bwkaz and updated the CLASSPATH and verified that the variable OOO_BASE_DIR was set with no luck. Made sure it was in the regular PATH also with no luck.

    The error said, however, an alternative classpath it was checking was /usr/share/java. I copied the two files over into that directory and it seems to have repressed the error message at least. I don't exactly love the solution, but it is working. Thanks!
    The Swain

    dswain

  4. #4
    Join Date
    Sep 2008
    Posts
    2
    Hi, I've been having the same exact problem. I've tried all sorts of stuff, from re-installing OOo to installing one of the betas to deleting the .openoffice2 directory, and nothing is working. I've also tried to copy the sdbc_hsqldb.jar to /usr/share/java. You said that you copied two files. What is the other one?

  5. #5
    Join Date
    May 2003
    Location
    New Jersey
    Posts
    1,258
    Those files are hsqldb.jar and sdbc_hsqldb.jar. If you can't find them or don't know where they are, try this command to locate them:

    Code:
    find / -name sdbc_hsqldb.jar
    If I recall correctly, they're in the same directory though. Either way, that technique worked for me. Hopefully it helps you too!
    The Swain

    dswain

  6. #6
    Join Date
    Sep 2008
    Posts
    2
    Quote Originally Posted by DSwain
    Those files are hsqldb.jar and sdbc_hsqldb.jar. If you can't find them or don't know where they are, try this command to locate them:

    Code:
    find / -name sdbc_hsqldb.jar
    If I recall correctly, they're in the same directory though. Either way, that technique worked for me. Hopefully it helps you too!
    I found the sdbc_hsqldb.jar file, but, I could not find the hsqldb.jar file. I found one on the internet and copied it to /usr/share/java, but now I'm getting a new error: "The connection to the data source "database-name" could not be established. General error: java.lang.UnsatisfiedLinkError: com.sun.star.sdbcx.comp.hsqldb.StorageFileAccess.i s.Stream.Element (Ljava/lang/String;Ljava/lang/String;)Z"

    I'm using Arch Linux, if that makes any difference.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •