using grub menu.lst to launch grub2 distro


Results 1 to 2 of 2

Thread: using grub menu.lst to launch grub2 distro

  1. #1
    Join Date
    Dec 2007
    Location
    Alabama
    Posts
    4

    [solved]using grub menu.lst to launch grub2 distro

    Not new to LInux but still dumb as dirt....

    I run PCLOS KDE 32 bit as my main distro on a multi-boot pc. PCLOS is located at /dev/sda9. In installed the grub2 distro at /dev/sda12. The grub2 disto overwrote the mbr and created the files that grub2 creates. Then, after doing the update after re-booting the grub2 distro, I booted into PCLOS and reset the MBR to use grub that is located on /dev/sda9. Now I haven't been able to get my menu.lst entry to let me back into /dev/sda12. Here is my entry in menu.lst:
    Code:
    title Solydk
    #set root='(/dev/sda,msdos12)'
    #kernel /boot/vmlinuz-3.2.0-4-686-pae root=UUID=a81ddce6-5725-4a89-8777-5a443be8ea0a ro  quiet splash
    #initrd /boot/initrd.img-3.2.0-4-686-pae
    root (hdo,11)
    chainloader +1
    As you can see, I commented out the three lines that didn't work. Needless to say the others didn't work either. I got grub error 23 with the commented out lines and grub 15 error with the uncommented lines.

    Here is the grub.cfg menu entry from the grub2 distro:
    Code:
    menuentry 'SolydXK GNU/Linux, with Linux 3.2.0-4-686-pae' --class solydxk --class gnu-linux --class gnu --class os {
    	load_video
    	set gfxpayload=800x600
    	insmod gzio
    	insmod part_msdos
    	insmod ext2
    	set root='(/dev/sda,msdos12)'
    	search --no-floppy --fs-uuid --set=root a81ddce6-5725-4a89-8777-5a443be8ea0a
    	echo	'Loading Linux 3.2.0-4-686-pae ...'
    	linux	/boot/vmlinuz-3.2.0-4-686-pae root=UUID=a81ddce6-5725-4a89-8777-5a443be8ea0a ro  quiet splash
    	echo	'Loading initial ramdisk ...'
    	initrd	/boot/initrd.img-3.2.0-4-686-pae
    }
    I have read quite a bit from 'How I did it" and the sticky 'Boot Tips'. It seems the more I read, the more confused I get. Can someone get me headed in the right direction to get the menu.lst entry correct?
    Thanks,
    Last edited by houndhen; 04-14-2013 at 10:10 PM.

  2. #2
    Join Date
    Dec 2007
    Location
    Alabama
    Posts
    4
    Sometimes it just helps to walk away. I got to thinking about the line 'root=(hd0,11) and once I edited it and saw that hdo was not hd0 as in zero, I was able to boot into the disro. Will mark this solved.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •