apache2 fails to start


Results 1 to 3 of 3

Thread: apache2 fails to start

  1. #1
    Join Date
    Jul 2003
    Posts
    2,014

    apache2 fails to start

    Hi all

    OS - Ubuntu 12.04 desktop 64bit running as VM
    Virtualizer Oracle VirtualBox
    airtime 2.2.1-1

    phpmyadmin NOT installed.

    $ sudo service apache2 start
    Code:
     * Starting web server apache2
    Syntax error on line 5 of /etc/apache2/sites-enabled/airtime-vhost:
    ServerAdmin takes one argument, The email address of the server administrator
    Action 'start' failed.
    The Apache error log may have more information.
       ...fail!
    $ tail /var/log/apache2/error.log
    Code:
    [Wed Jan 16 15:26:06 2013] [notice] Apache/2.2.22 (Ubuntu) configured -- resuming normal operations
    [Wed Jan 16 15:26:07 2013] [notice] caught SIGTERM, shutting down
    [Wed Jan 16 15:26:08 2013] [notice] Apache/2.2.22 (Ubuntu) PHP/5.3.10-1ubuntu3.4 with Suhosin-Patch configured -- resuming normal operations
    [Wed Jan 16 15:34:43 2013] [notice] caught SIGTERM, shutting down
    Please advise where to check and how to fix the problem? TIA

    B.R.
    satimis

  2. #2
    Join Date
    Oct 2000
    Location
    Sweden
    Posts
    494
    If you read the error message carefully, you can see this line:
    "Syntax error on line 5 of /etc/apache2/sites-enabled/airtime-vhost:"
    So edit that file, look for "ServerAdmin".
    In pingvino veritas!

  3. #3
    Join Date
    Jul 2003
    Posts
    2,014
    Quote Originally Posted by x View Post
    If you read the error message carefully, you can see this line:
    "Syntax error on line 5 of /etc/apache2/sites-enabled/airtime-vhost:"
    So edit that file, look for "ServerAdmin".
    Hi,

    cat /etc/apache2/sites-enabled/airtime-vhost
    Code:
    <VirtualHost *:80>
          ServerName icecast.mydomain.com
          #ServerAlias Example Domain
    
          ServerAdmin root@localhost An email address is required for the virtual host configuration.     
    
          DocumentRoot /usr/share/airtime/public
          DirectoryIndex index.php
    
          SetEnv APPLICATION_ENV "production"
    
          <Directory /usr/share/airtime/public>
                  Options -Indexes FollowSymLinks MultiViews
                  AllowOverride All
                  Order allow,deny
                  Allow from all
          </Directory>
    </VirtualHost>
    After deleting "An email address is required for the virtual host configuration." then it works

    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •