New to Linux - Webmin Error


Results 1 to 2 of 2

Thread: New to Linux - Webmin Error

  1. #1
    Join Date
    Feb 2013
    Posts
    1

    Exclamation New to Linux - Webmin Error

    Hello community and experts,

    I am new to this forum and Linux. I've been doing a significant amount of research on Storage/Media servers. Most people are recommending using Linux Server, run XEN for you VM, and use the VM's for your software you want to run.

    I installed the Linux Unbuntu Server 12.04.1 LTS, XEN, and Webmin. I installed PuTTY on another machine so I can disconnect the monitor and keyboard. Linux Server is a bit complex as everything has to be done through command line (It'll take time to learn :P).

    In the meantime, I installed Webmin to have some form of GUI for the server. When I run the command:
    curlyp@Linux-Server-Main:~$ sudo /etc/webmin/start I receive and error. Here is the error I receive:

    Starting Webmin server in /usr/share/webmin
    Pre-loaded WebminCore
    Failed to bind to port 10000 : Address already in use
    Could not listen on any portscurlypl@Linux-Server-Main:~$ ^C


    So, I ran netstat to see what is using the 10000. Here is the results:

    Active Internet connections (w/o servers)
    Proto Recv-Q Send-Q Local Address Foreign Address State
    tcp 0 0 X.X.X.X:ssh X.X.X.X:62369 ESTABLISHED
    Active UNIX domain sockets (w/o servers)
    Proto RefCnt Flags Type State I-Node Path
    unix 7 [ ] DGRAM 7672 /dev/log
    unix 3 [ ] STREAM CONNECTED 10522
    unix 3 [ ] STREAM CONNECTED 10521
    unix 2 [ ] DGRAM 10481
    unix 2 [ ] DGRAM 9338
    unix 3 [ ] STREAM CONNECTED 8036 /var/run/xenstored/socket
    unix 3 [ ] STREAM CONNECTED 8035
    unix 3 [ ] STREAM CONNECTED 9259 /var/run/dbus/system_bus_socket
    unix 3 [ ] STREAM CONNECTED 7985
    unix 3 [ ] STREAM CONNECTED 7992 /var/run/xenstored/socket
    unix 3 [ ] STREAM CONNECTED 9258
    unix 2 [ ] DGRAM 9254
    unix 2 [ ] DGRAM 7970
    unix 2 [ ] DGRAM 7833
    unix 3 [ ] STREAM CONNECTED 7655 @/com/ubuntu/upstart
    unix 3 [ ] STREAM CONNECTED 7649
    unix 3 [ ] STREAM CONNECTED 7617 /var/run/dbus/system_bus_socket
    unix 3 [ ] STREAM CONNECTED 7616
    unix 3 [ ] STREAM CONNECTED 7581
    unix 3 [ ] STREAM CONNECTED 7580
    unix 3 [ ] DGRAM 6865
    unix 3 [ ] DGRAM 6864
    unix 3 [ ] STREAM CONNECTED 6806 @/com/ubuntu/upstart
    unix 3 [ ] STREAM CONNECTED 6803


    I don't see port 10000 being used. If anyone has any advice on how to fix this issue so I can use Webmin I would appreciate it.

    Thanks for reading!

    CP

  2. #2
    Join Date
    Mar 2013
    Location
    Cheltenham, Gloucestershire, UK
    Posts
    4
    Hello Curlyp,

    If you run the below command it should also give you the application name which is using the port:
    netstat --listening

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  









×
We have made updates to our Privacy Policy to reflect the implementation of the General Data Protection Regulation.