Grub Error 15 (SOLVED)


Results 1 to 3 of 3

Thread: Grub Error 15 (SOLVED)

  1. #1
    Join Date
    Sep 2008
    Posts
    33

    Grub Error 15 (SOLVED)

    Hi all,

    This problem is solved, I'm only posting this in the hope that it may help others.

    A while ago, after no updates/changes that I was aware of, my system stopped booting, and gave me:

    Code:
    GRUB Loading stage1_5
    
    GRUB Loading, please wait
    Error 15
    The error is in stage 1.5, not stage2, as there is no more info on screen. However, the grub manual tells us that stage 1.5 errors have the same explanations as stage2, and error 15 is "File not found". Presumably, Grub couldn't find stage2. However, after booting with a Grub CD, a quick check shows that the stage2 and all other stuff normally present is there. Furthermore, boot_info_script says all is hunky-dory,
    Code:
    Grub Legacy (v0.97) is installed in the MBR of /dev/sda and looks on the 
        same drive in partition #1 for /boot/grub/stage2 and /boot/grub/menu.lst.
    
    Grub Legacy (v0.97) is installed in the boot sector 
                           of sda1 and looks at sector 17179431 of the same hard 
                           drive for the stage2 file.  A stage2 file is at this 
                           location on /dev/sda.  Stage2 looks on partition #1 
                           for /boot/grub/menu.lst.
    Checked that menu.lst and fstab were ok.
    Furthermore, using the Grub CD I could boot sda1 by using the chainloader +1 command, and using the configfile command brought up the sda1 menu screen in all its multiple-choice glory.

    So presumably something is corrupt in the MBR. Easily fixed, I thought, just start up with the Grub CD, and enter
    Code:
    root (hd0,0)
    setup (hd0)
    Grub happily executed this, reported no errors. Only problem, the system still wouldn't boot normally. Re-installed Grub using apt-get, and ran grub-install. Not fixed. Perhaps sda1 has a corrupted filesystem? Ran e2fsck: no change.
    Ran setup again to make the MBR look at a different partition for stage2 and menu.lst. Still no joy.
    Tried running the find command from the Grub CD. Not one of the twenty-plus stage1 or stage2 files could be found, though boot_info_script found them all. Hmm.

    Well, maybe my hard disc is is dying. This seemed the more likely since there's a little man in my computer who has a sudden tantrum from time to time and throws spanners around. I can check by opening the box and disconnecting the first HD, and trying to get it to boot off the MBR on the second HD, or, wait, I can swap the boot order in the BIOS. Which I did. Still no joy! WTF!

    Rebooted into BIOS to change back to the normal order, and saw the option F10: Flash BIOS. Well, why not? Can't think of anything else to do.

    And would you believe it? BINGO!

    Footnote: The little man with the spanners turns out to be a knackered bearing on the CPU fan.

  2. #2
    Join Date
    Mar 2013
    Posts
    1
    up ph? bác, chúc bác d?t h*ng :d

  3. #3
    Join Date
    Sep 2008
    Posts
    33
    Quote Originally Posted by hieu.hap View Post
    up ph? bác, chúc bác d?t h*ng :d
    Well, yes, I'm afraid I did use some of that sort of language.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •