Problem: No internet connection over ethernet

Internet provider: Post Office
Operating system: Xubuntu 12.10

The connection works fine over wireless. The wired connection works when I run it to a Windows 7 computer. It's just not working when I try and connect the same line (same ethernet cable, even), to Xubuntu.

This problem is verified on two separate Xubuntu machines: A) Xubuntu Laptop and B) Xubuntu Desktop. A third machine worked fine using the same equipment / cable / connection: C) Windows 7 Desktop.

The problem is also verified using two routers:
1. ZyXEL router : AMG1202-T10A, supplied by the ISP
2. BT Home Hub 3 : my old router that worked fine before.

The Post Office cannot help because it does not support Linux.*

Both computers, A & B, worked fine over wireless and wired ethernet connection to the BT Home Hub, using a BT ADSL line. They worked on this basis without problem for the last year. Prior to that they worked over a Virgin connection without problem.

What's changed: new house, new ISP. But this shouldn't make any difference. And now even the old router doesn't want to give a wired connection to these machines (see below).

Same computers. Same cables. Same operating systems. The Post Office got my broadband connected this morning. They resell a BT ADSL line. So it's effectively what I had before.

The Xubuntu Laptop has been connected during the last three weeks to a friendly neighbour's wireless BT ADSL router.

I connected the ZyXEL router to the Post Office ADSL line this morning. Everything online: looking good. All green lights. But wired connection was not possible to either Xubuntu Laptop or Xubuntu desktop.

Using the same cable, a Windows 7 machine got a Post Office internet connection via the same ZyXEL router without a problem.

Using wireless, the Xubuntu laptop was able to get a Post Office internet connection via the ZyXEL router. It just can't get a wired connection.

Connected the the Linux Desktop and the Windows 7 Desktop to the old router: the BT Home Hub 3. The Xubuntu Desktop was not able to access the router settings page ( The Windows 7 Desktop was able to access the Hub settings.

Both Xubuntu computers go through the motions of making the wired connection to both routers. Each displays a connected status in the network indicator, indicating that the computer is connected over ethernet to the router. But neither machine can connect to an internet server when attempt made through web browser.

All of the connections here were tested by opening Firefox. All installations have worked fine on other connections. I tried Chrome on the Xubuntu desktop as well. That also failed to get a connection.

When attempting a connection through the ZyXEL roueter, Firefox said: "Server not found. Firefox can't find the server at ..."

When attemting a connection to the BT Home Hub settings, Firefox said: "Unable to connect. Firefox can't establish a connection to the server..."

Both these computers worked fine at the last address and with the last ISP, which was BT. But they also both connected to BT via the BT Home Hub. Now they can't even access the BT Home Hub settings.

* ( Bad choice of ISP, you might say - they do seem good in many other ways though. And their tech support guys do all they can to help, even if they don't have a single resident Linux expert). And they were more helpful than BT used to be. BT doesn't support Linux either.