Greetings to all!

I can send mail locally and I can send mail OUT to the world, but I do not receive mail from the world. Port 25 is not bound. I can't figure out how to bind it.

The setup is as follows:

basic Intel box (P4)
Ubuntu 12.04 LTS
uname -a ==> Linux treemstr2 3.5.0-23-generic #35~precise1-Ubuntu SMP Fri Jan 25 17:15:33 UTC 2013 i686 i686 i386 GNU/Linux

I installed exim-4.80.1 from source and it did not work. I was informed that Ubuntu is a Debian-type OS and that I should obtain exim by choosing one of a few types; I decided to use "exim-daemon-heavy" which installed cleanly and removed postfix and daemonized exim. The typical "exim.conf" is not part of the mix here. Instead, there is a configuration file that is autogenerated using a script and update process. That appears to be okay, but I obviously have missed the correct answer to one or more of the questions because exim is NOT listening on port 25. Here is my nmap report:

root@treemstr2:/etc# nmap localhost

Starting Nmap 5.21 ( ) at 2013-10-16 23:51 CDT
Nmap scan report for localhost (
Host is up (0.000014s latency).
Not shown: 990 closed ports
21/tcp open ftp
22/tcp open ssh
80/tcp open http
110/tcp open pop3
139/tcp open netbios-ssn
143/tcp open imap
445/tcp open microsoft-ds
993/tcp open imaps
995/tcp open pop3s
9000/tcp open cslistener

Nmap done: 1 IP address (1 host up) scanned in 0.11 seconds
Here is the exim configuration file content:

# /etc/exim4/update-exim4.conf.conf
# Edit this file and /etc/mailname by hand and execute update-exim4.conf
# yourself or use 'dpkg-reconfigure exim4-config'
# Please note that this is _not_ a dpkg-conffile and that automatic changes
# to this file might happen. The code handling this will honor your local
# changes, so this is usually fine, but will break local schemes that mess
# around with multiple versions of the file.
# update-exim4.conf uses this file to determine variable values to generate
# exim configuration macros for the configuration file.
# Most settings found in here do have corresponding questions in the
# Debconf configuration, but not all of them.
# This is a Debian specific file

dc_other_hostnames=' ; ;'
dc_local_interfaces=' ; XXX.YYY.ZZZ.TTT ; ::1'
The XXX.YYY.ZZZ.TTT is my static IP
The MX record is correctly listed with my domain registrar.

I have looked all over the place, and cannot find any hints on why port 25 is not listed nor how to get exim to listen on it.

Most of the posts I've seen are a couple years old and the suggestions refer to things (config files, for example) that are no longer part of the Debian-like layout.

I have another old computer and I suppose I could host the email on a separate computer from the one hosting the website and then I could use a different OS and build exim from source as I have done before (with lots of help from kind folks here, I should say!).

When I attempt a "mock" delivery using "swaks", the following occurs:

root@treemstr2:/etc# swaks -a -tls -q AUTH -s -au john
Password: jhs1234
=== Trying
*** Error connecting to
*** IO::Socket::INET: connect: Connection refused
I have considered the line "dc_local_interfaces=' ; XXX.YYY.ZZZ.TTT ; ::1' " that perhaps XXX.YYY.ZZZ.TTT:25 might work, but that doesn't make sense if you don't need it for the loopback, why would you need it for the outside!

Anyone have an idea. I'm pulling my hair out and it's getting a bit thin on top!