I am a complete linux newbie here so be patient.

I have recently installed Red Hat 8.0 (2.4.18 I think) with xFree86 4.2. I have tried to get my Radeon 9000Pro 64Mb to work with varying results (I had a quick search through this forum and haven't found owt to help) this is what happens....

Installing Red Hat - Anaconda autodetects the Radeon 9000 Pro.
Manage to run 1280x1024x24bit fine except the screen is a bit off-centre and the extreme right is off the screen. This works fine if a switch to DVI input on the monitor. Display drivers report as vesa. When trying to do anything 3d the display goes all mad (diagonal stripes and so on)

Downloaded the xfree86 4.2 driver from ATI and run (according to ATI's instructions) and run the fxglrconfig (or whatever its called). xfree comes back up and the driver now reports as unknown. Still no option for hardware 3d acceleration. 3d stuff still doesn't work. Also when I look at the display config it will not let me set it at anything higher than 640x480x8bit even though it is still running at 1280x1024x24bit.

When I next boot the system, xfree86 fails with a garbled error message and after some random keypressing it seems to manage to come back up - but the display drivers have gone back to defaults.

I've got a couple of options...

1. The linux kernel or xfree86 isn't compatible with the video card.
2. The driver isn't compatible with the same
3. The driver isn't compatible as it is not a true ATI card (its a sapphire)
4. I'm a complete idiot and have done something dumb.

I reckon its probably 4.

It's really annoying me as I've spent ages trying to get linux up and running and was dead happy that I'd finally got me modem working and now this. :-(

In case it helps my system is...

Dell Dimension 8100
Pentium 4 1.4Ghz
INtel 845 motherboard (I think)
Sapphire Atlantis Radeon 9000Pro 64Mb DDR
Dell 17" FPD
Red Hat Linux 8 (2.4.18)
xFree86 4.2

Cheers for any help you can give me. I'll continue searching this forum and the web....