How do I make GKRELLM start automatically when the system starts


Results 1 to 12 of 12

Thread: How do I make GKRELLM start automatically when the system starts

  1. #1
    Join Date
    Mar 2002
    Location
    Baltimore
    Posts
    26

    How do I make GKRELLM start automatically when the system starts

    Please help and please explain in still a noob.

    RX

  2. #2
    Join Date
    Apr 2003
    Location
    Buenos Aires, Argentina
    Posts
    4,221
    You have to edit your .xinitrc (in your home directory).

    Here's an example:
    gkrellm &
    exec pekwm
    Note the &, also, be sure that "gkrellm" is before "exec <your window manager>".
    djserz.com.ar
    "All the drugs in this world won't save you from yourself..."

  3. #3
    Join Date
    Mar 2002
    Location
    Baltimore
    Posts
    26
    Sorry...I cant find it under home....RH9 by the way.

    RX

  4. #4
    Join Date
    Jul 2003
    Posts
    231
    should be in /etc/X11/xinit

  5. #5
    Join Date
    Jul 2003
    Location
    AK
    Posts
    429
    for RH9, the file you want is in /etc/X11/gdm/Sessions/

    you just edit the text file that cooresponds to the window manager you are using... the command serz gives should work good... you just add `gkrellm &` to the top of whatever session file suits you...

  6. #6
    Join Date
    Mar 2002
    Location
    Baltimore
    Posts
    26
    Thanks all...Im a straight newb...How do I figure out which windows manager im using. I havent changed anything from the default install.

    RX

  7. #7
    Join Date
    Feb 2002
    Location
    NC, USA
    Posts
    33
    If you are using the default, then you should be using GNOME. Try this. Click on Main Menu -> Preferences -> More Preferences -> Sessions. There is a tab for startup programs and you can add /usr/bin/gkrellm to it. This should do it.
    AMD Athlon 1.3 Ghz
    Fedora Core 1
    512 MB RAM
    Nvida Riva TNT2 Video Card

  8. #8
    Join Date
    Mar 2002
    Location
    Baltimore
    Posts
    26
    lol...oops...im sorry....Using KDE.

    RX

  9. #9
    Join Date
    Feb 2002
    Location
    NC, USA
    Posts
    33
    I think you should be able to do it the same way in KDE on redhat-9.

    Or you can start gkrellm and logout without closing it. By default KDE restarts the old session.
    Last edited by funnyjedi; 11-13-2003 at 03:22 PM.
    AMD Athlon 1.3 Ghz
    Fedora Core 1
    512 MB RAM
    Nvida Riva TNT2 Video Card

  10. #10
    Join Date
    Mar 2002
    Location
    Baltimore
    Posts
    26
    2 Things guys.....First of all....When I got to prefs, more prefs, sessions...Nothing happens. 2nd I cant find the initrc file. Its not in etc/x11/gdm/sessions

    RX

  11. #11
    Join Date
    Oct 2002
    Location
    NC, USA
    Posts
    22
    RX - which version of KDE and Gkrellm you using? There is a problem with some versions of gkrellm not restarting automatically in KDE 3.1.4. Supposedly fixed with the newest gkrellm build, but I haven't tried it yet.

  12. #12
    Join Date
    Feb 2002
    Location
    NC, USA
    Posts
    33
    edit this file
    /etc/X11/gdm/Sessions/KDE

    #!/bin/bash

    exec /etc/X11/xdm/Xsession kde

    Add gkrellm & before the exec line.
    So this is how the new KDE file will look

    #!/bin/bash

    gkrellm &
    exec /etc/X11/xdm/Xsession kde

    this will start gkrellm for everyone on your computer who logs in using KDE though.
    AMD Athlon 1.3 Ghz
    Fedora Core 1
    512 MB RAM
    Nvida Riva TNT2 Video Card

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •