Lufs installation errors in Mandrake 10


Results 1 to 4 of 4

Thread: Lufs installation errors in Mandrake 10

  1. #1
    Join Date
    Oct 2003
    Location
    Oxford, England
    Posts
    151

    Lufs installation errors in Mandrake 10

    Hi all
    I am trying to install lufs. Now wehn I run the ./ configure script I get this error message. Can anybody tell me how to correct this.
    [root@sauryalap lufs-0.9.7]# ./configure
    checking build system type... i686-redhat-linux-gnu
    checking host system type... i686-redhat-linux-gnu
    checking target system type... i686-redhat-linux-gnu
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for gawk... gawk
    checking whether make sets $(MAKE)... yes
    checking OS... Linux
    checking kernel... 2.6.3-7mdk
    checking kernel support... supported in kernel/Linux/2.6
    checking kernel headers... found in /lib/modules/2.6.3-7mdk/build/include
    checking kernel configuration... found, using modversions
    checking modversions.h... configure: error: not found!
    Thanks
    SS
    Linux Newbie
    Expermienting with Mandrake 9.2 and SuSE 9
    AJP/Clevo laptop-866MHz PIII,384MB SDRAM

  2. #2
    Join Date
    Mar 2003
    Location
    Augusta, GA
    Posts
    5,461
    My guess would be that the kernel sources need to be installed, therre should be a mandrake package available or you could get the sources from the kernel.org site and uncompress them in /usr/src. You may need to make a symbolic link to the sources for the config programs to find them. Look in the Howto forum for threads on installing a 2.6 kernel. You just need the sources installed and linked.
    __________________________________________________ _______________________________________
    Bigboogie on boogienights.net:
    Ammo case
    Asus 8N32 SLI MB
    AMD Athlon x2 3800+
    2 GB Patriot Signature 400 DDR
    160 GB Hitachi 7200 IDE
    2 x-250 Seagate SATA2
    EVGA Nvidia 7900GT
    Dell 2007WFP
    Logitech 5.1 speakers
    Logitech MX1000 mouse
    Dell USB keyboard
    NEC 3500 DVD-RW
    Benq 1655 DVD-RW



    (God bless tax refunds)

  3. #3
    Join Date
    Oct 2003
    Location
    Oxford, England
    Posts
    151
    Hi hard candy
    The kernel source is already installed. Here is the putput which shows that.
    [ssaurya@sauryalap Desktop]$ rpm -qa|grep kernel-source
    kernel-source-2.6.3-7mdk
    Any ideas.
    SS
    Linux Newbie
    Expermienting with Mandrake 9.2 and SuSE 9
    AJP/Clevo laptop-866MHz PIII,384MB SDRAM

  4. #4
    Join Date
    Mar 2003
    Location
    Augusta, GA
    Posts
    5,461
    You may want to double check, but I think that you need to configure the kernel sources (you can probably accept the default configuration) and run "make" to generate the modversions header file. I would research this some more or wait for someone with more experience to double check this. (After writing that, I think that as long as you did not actually install the kernel, it probably would not mess anything up). Or double check that "/usr/src/linux/include/linux/modversions.h." is present. If not, you may need to do the above.
    __________________________________________________ _______________________________________
    Bigboogie on boogienights.net:
    Ammo case
    Asus 8N32 SLI MB
    AMD Athlon x2 3800+
    2 GB Patriot Signature 400 DDR
    160 GB Hitachi 7200 IDE
    2 x-250 Seagate SATA2
    EVGA Nvidia 7900GT
    Dell 2007WFP
    Logitech 5.1 speakers
    Logitech MX1000 mouse
    Dell USB keyboard
    NEC 3500 DVD-RW
    Benq 1655 DVD-RW



    (God bless tax refunds)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •