To get your Wheel Mouse to work with all the buttons, including the back forward buttons on the left side of the mouse:

For Xfree (/etc/X11/XF86Config)
Section "InputDevice"

        Identifier      "Intellimouse"
        Driver          "mouse" 
        Option          "Protocol"              "IMPS/2"
        Option          "Device"                "/dev/usbmouse"
        Option          "Buttons"               "7"
        Option          "ZAxisMapping"          "6 7"

To remap the buttons (~/.xsession (or whatever other startup script you are using)
#remap the mouse pointer buttons
xmodmap -e "pointer = 1 2 3 6 7 4 5"
For the back / forward buttons

Install xvkbd |

In your settings for your keybinds/mousebinds in your WM or DE:

set mouse button 6 to:
xvkbd -xsendevent -text "\[Alt_L]\[Left]"

set mouse button 7 to:
xvkbd -xsendevent -text "\[Alt_L]\[Right]"

(NOTE: These settings will work even if you do not set up the back/forward buttons)