TV card just stopped working in Suse 9.1


Results 1 to 12 of 12

Thread: TV card just stopped working in Suse 9.1

  1. #1
    Join Date
    Jan 2003
    Posts
    27

    TV card just stopped working in Suse 9.1

    I had been using my leadtek xp deluxe just fine, until yesterday I turn on kdetv and tells me no device found. So I go over to Yast and my tv card is there, but when I hit scan the channels I get : "v4l2: open /dev/video0: No such file or directory Number of TV stations found: 0."

    I haven't made any changes to my system, It just stopped working. Any ideas?

    oh and one other thing, on the infrared control config the ir-kbd-i2c kernel module worked fine, but now I get an application not responding error.

  2. #2
    Join Date
    Jul 2002
    Location
    Vladivostok, Russia
    Posts
    9,054
    Pay your cable bill ..seriously though I have no idea, but stick around ....the answer will come.
    "I was pulled over for speeding today. The officer said, "Don't you know
    the speed limit is 55 miles an hour?" And I said, "Yes, but I wasn't going
    to be out that long."

    How To Ask Questions The Smart Way
    COME VISIT ME IN RUSSIA NOW!!

  3. #3
    Join Date
    Dec 1999
    Location
    Toronto
    Posts
    39,320
    Does /dev/video0 exist?

    ls -al /dev/video0

    Is v4l or v4l2 still being loaded in your X config.

    Section "Module"
    Load "v4l"
    EndSection
    SEARCH FIRST... ASK SECOND Read the JL 'Community Help Posting Guidelines' before posting in the forums.

    Precompiled Redhat NTFS Modules

    Linuxplanet Tutorials

    If Linux doesn't have the solution, you have the wrong problem. ... Please do not send me a PM asking for help...

    Please read the search suggestion thread in JL Ideas

  4. #4
    Join Date
    Apr 2003
    Location
    Iceland
    Posts
    290
    I had the same problem few days ago, my tv card stopped working. All i had to do was open the Suse hardware tool (icon of pci card in the right corner) then pops up "Devicemanager", click on "tvcard" -"Brooktree bt878"
    then "details" and it tells you the status of the card, i opened the driver button and it said:

    "Driver Info #0:
    Driver status: bttv is inactive
    Driver activation Cmd: "modprobe bttv"

    Ran "modprobe bttv" in a konsole as su and problem solved.
    Last edited by frimann; 06-25-2004 at 12:32 PM.

  5. #5
    Join Date
    Jan 2003
    Posts
    27
    Thanks for the replies, I checked these things out and nothing seems out of place. but I still get
    v4l2: open /dev/video0: No such file or directory
    When I try to scan for channels.

    I can do: modprobe -l |grep bttv and get
    /lib/modules/2.6.4-54.5-default/kernel/drivers/media/video/bttv.ko

    and modprobe -l |grep v4l and get
    /lib/modules/2.6.4-54.5-default/kernel/drivers/media/video/v4l1-compat.ko
    /lib/modules/2.6.4-54.5-default/kernel/drivers/media/video/v4l2-common.ko

    but no /dev/video0 directory exists. Maybe try creating it myself allowing rw access for everything?

    v4l module is being loaded and is in my x config. The problem seems to be this directory.

  6. #6
    Join Date
    Apr 2001
    Location
    SF Bay Area, CA
    Posts
    14,947
    It's a device file, not a directory.

    Have you checked in /dev for whether you actually do have a video0 file?

    Does SuSE use devfs or udev? If not, then there's no reason that you can't just create /dev/video0 yourself (but then, there's no reason it should have disappeared either). But if it does use one of them, then the manually created device file won't persist (at least not with a default source installation of udev or devfs) across a reboot.

    How many files do you have in /dev? "ls /dev | wc -l" will tell you. That should be a good way to tell whether some dynamic /dev management function is in use.

    Do you have a /dev/video1 or something like that? If so, does it work to point kdetv at that device file instead?

  7. #7
    Join Date
    Dec 1999
    Location
    Toronto
    Posts
    39,320
    From SuSE 9.0 and created during the initial installation.

    ls -al /dev/video*

    Code:
    lrwxrwxrwx    1 root     root            6 Jan  3 09:31 /dev/video -> video0
    crw-------    1 root     video     81,   0 Sep 23  2003 /dev/video0
    crw-------    1 root     video     81,   1 Sep 23  2003 /dev/video1
    crw-------    1 root     root     171,  16 Sep 23  2003 /dev/video1394
    crw-------    1 root     video     81,   2 Sep 23  2003 /dev/video2
    crw-------    1 root     video     81,   3 Sep 23  2003 /dev/video3
    SEARCH FIRST... ASK SECOND Read the JL 'Community Help Posting Guidelines' before posting in the forums.

    Precompiled Redhat NTFS Modules

    Linuxplanet Tutorials

    If Linux doesn't have the solution, you have the wrong problem. ... Please do not send me a PM asking for help...

    Please read the search suggestion thread in JL Ideas

  8. #8
    Join Date
    Jan 2003
    Posts
    27
    Ok, when I do ls -al /dev/video* I get

    rwxrwxrwx 1 root root 6 Jun 16 21:15 /dev/video -> video0
    crw------- 1 root video 81, 1 Apr 6 06:27 /dev/video1
    crw------- 1 root root 171, 16 Apr 6 06:27 /dev/video1394
    crw------- 1 root video 81, 2 Apr 6 06:27 /dev/video2
    crw------- 1 root video 81, 3 Apr 6 06:27 /dev/video3

    It seems like I'm missing the video0 entry there.

    ls /dev | wc -l results in 7467

    I don't seem to have any option in kdetv to specify anything, as the lists are blank, so no trying video1.

    but is /dev/video -> video0 like a symbolic link? In that case maybe I could link it to video1 or anything else? I think I'll try that.

  9. #9
    Join Date
    Apr 2001
    Location
    SF Bay Area, CA
    Posts
    14,947
    Originally posted by Everman
    Ok, when I do ls -al /dev/video* I get

    rwxrwxrwx 1 root root 6 Jun 16 21:15 /dev/video -> video0
    crw------- 1 root video 81, 1 Apr 6 06:27 /dev/video1
    crw------- 1 root root 171, 16 Apr 6 06:27 /dev/video1394
    crw------- 1 root video 81, 2 Apr 6 06:27 /dev/video2
    crw------- 1 root video 81, 3 Apr 6 06:27 /dev/video3

    It seems like I'm missing the video0 entry there.
    Yes, you are.

    ls /dev | wc -l results in 7467
    OK, you're using just a plain static /dev directory then (I'm using udev, and I have about 150 files; when I had devfs, it was somewhere in the same neighborhood -- maybe higher, but nowhere NEAR 7 thousand). You can just recreate /dev/video0, like so (you will have to be root):

    Code:
     cd /dev
     mknod video0 c 81 0
    man mknod to see what this is all about.

    If the symlink doesn't work (and I don't think it will, but I suppose it's worth a shot anyway), then do this and make the symlink point back at video0.

  10. #10
    Join Date
    Jan 2003
    Posts
    27
    Thanks bwkaz, looks like that did it. Picture quality isn't as good as it used to be but maybe I can fine tune it.

    One strange thing though, in Yast I get
    vbi: open failed [/dev/vbi] when I click scan for channels, but I get all the channels in kdetv.

    So I guess it works and doesn't quite at the same time
    Thanks for the help though, I never knew about the mknod command.

  11. #11
    Join Date
    Dec 1999
    Location
    Toronto
    Posts
    39,320
    Originally posted by Everman
    I never knew about the mknod command.
    Lots of great commands (programs) in

    /bin
    /usr/bin
    /sbin
    /usr/sbin

    Never, ever execute any unless you know what you are doing. Refer to the manpages to find out what they do and their available options.

    Do a

    ls /dev | wc -l

    on each of those directories just to find out how many commands you have available in those four directories.
    SEARCH FIRST... ASK SECOND Read the JL 'Community Help Posting Guidelines' before posting in the forums.

    Precompiled Redhat NTFS Modules

    Linuxplanet Tutorials

    If Linux doesn't have the solution, you have the wrong problem. ... Please do not send me a PM asking for help...

    Please read the search suggestion thread in JL Ideas

  12. #12
    Join Date
    Apr 2001
    Location
    SF Bay Area, CA
    Posts
    14,947
    /dev/vbi is generally a symlink to /dev/vbi0, which can be created with a:

    cd /dev
    mknod vbi0 c 81 224

    as root. (If you have any other "missing" devices, check <kernel source directory>/Documentation/devices.txt to find out what to use for the numbers. The first number given to mknod is the major, and the second is the minor.)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •