Mounting a Partition as /home


Results 1 to 12 of 12

Thread: Mounting a Partition as /home

  1. #1
    Join Date
    Apr 2004
    Location
    New York
    Posts
    147

    Mounting a Partition as /home

    I currently have two partitions on a hard drive. The first is an ext3 partition, and the second is a FAT32 partition.

    The mount point of the ext3 partition is /.

    I formatted the FAT32 partition after installing Fedora. I want to mount the FAT32 partition as /home. How do I do this?

    Thanks

  2. #2
    Join Date
    Aug 2001
    Location
    Somewhere, Texas
    Posts
    9,628

    Re: Mounting a Partition as /home

    Originally posted by Stupid Boy
    I formatted the FAT32 partition after installing Fedora. I want to mount the FAT32 partition as /home. How do I do this?
    DON'T
    FAT32 is a terrible filesystem, just look at how often it needs to be defraged and it's tendency to corrupt files. Using FAT32 as /home is a very bad idea.
    ext3 is a good choice as usually /home is full of lots of small files (config settings) and other misc things.

    never ever ever never ever ever use fat!

    other then that, "mount -t vfat /dev/hdb1 /home" should do it

  3. #3
    Join Date
    Apr 2004
    Location
    New York
    Posts
    147
    I'm just using FAT32 because I'm a moron so I'm using Norton Ghost to backup the partition.

  4. #4
    Join Date
    Aug 2001
    Location
    Somewhere, Texas
    Posts
    9,628
    Just letting you know FAT is a bad idea

    Are you backing it up with Ghost now, or will be using Ghost to back it up?
    Ghost does support Linux partitions

  5. #5
    Join Date
    Apr 2004
    Location
    New York
    Posts
    147
    As root, I did mount -t blah, blah, and the partition is definately mounted as /home.

    I then logged into the another user, whom I named "g7," but my session lasted less than 10 seconds. I deleted that user and tried again, but I still get the error.

    The error is:
    /etc/X11/gdm/PreSession/Default: Registering your session with wtmp and utmp
    /etc/X11/gdm/PreSession/Default: running: /usr/bin/X11/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "/var/gdm/:0.Xservers" -h"" -l":0" "g7"

    (gnome-session:13922): libgnomevfs-WARNING **: Unable to create ~/.gnome directory: Permission denied
    Could not create per-user gnome configuration directory '/home/g7/.gnome2/': Permission denied
    When I attempt to change /home/g7's owner from root to g7, I get:

    The owner could not be changed.
    Sorry, couldn't change the owner of "g7".
    1. What do I do to make this work?
    2. Is vfat the same as FAT32?

    About Ghost: as far as I know, Ghost can read Linux partitions but cannot write to them.

    After rebooting, I can login as g7 for more than 10 seconds, and the FAT32 partition is not mounted.
    Last edited by Stupid Boy; 06-29-2004 at 02:33 PM.

  6. #6
    Join Date
    May 2002
    Posts
    1,449
    Looks like a permission problem. What distro are you using? If your using Mandrake, Fedora or a similar distro there should be a easy-to-use GUI tool for adding a user, that should create the home directory with all the correct permissions.

    Try refering to your particular distro's help files and documentation for information on creating a new user.
    "I know where you're from but where do you belong?"

  7. #7
    Join Date
    Nov 2002
    Location
    Cape Town
    Posts
    40
    Hi there

    Your problem sounds most definitely to do with permissions on the /home partition. There are two places where you may want to check this out.

    First, from the command prompt, type: cd /
    This should take you into the root of the file system. Then type: ls -l
    This will list all of the folders in the root directory. Look for the entry that describes /home , and tell us what the nine little letters that come at the very beginning of its line are. This will go a long way towards working out what your problem is.
    It's possible that even though you created /home as root, you don't have permission to write to it. In which case it's easy to fix.

    Second, have a look at the /etc/fstab file. This file lists all of the mount points that will automatically be mounted when you boot up. Simply entering the mount command won't guarantee that the /home folder gets mounted every time. If it is there, check out the options and make sure you haven't specified that the partition be mounted ro (read only).

    Just thoughts [ use them | don't use them ]

  8. #8
    Join Date
    Aug 2002
    Location
    Delaware
    Posts
    4,310
    Thirdly, vfat doesn't support permissions, so you CAN'T use it as /home
    irc.freenode.net #justlinux The Not So Official JL IRC Channel.
    Debian Apt-Get

  9. #9
    Join Date
    Jul 2002
    Location
    Worcester, MA
    Posts
    208
    Try "mount /home" and then see if it's mounted. If it's in /etc/fstab, that should mount it although it should be mounted during a reboot as well. Try posting the ouput from "cat /etc/fstab" and "ls -l /".

  10. #10
    Join Date
    Nov 2002
    Location
    Cape Town
    Posts
    40
    Originally posted by sharth
    Thirdly, vfat doesn't support permissions, so you CAN'T use it as /home
    Duh!
    /me slaps self upside head.

    Good point, sharth.

  11. #11
    Join Date
    Dec 1999
    Location
    Toronto
    Posts
    39,320
    You will loose all your Linux filesystem permissions if you mount /home to a fat/fat32 partition and cause all sorts of problems as you've already noticed.

    Don't use fat/fat32 for a Linux filesystem.
    SEARCH FIRST... ASK SECOND Read the JL 'Community Help Posting Guidelines' before posting in the forums.

    Precompiled Redhat NTFS Modules

    Linuxplanet Tutorials

    If Linux doesn't have the solution, you have the wrong problem. ... Please do not send me a PM asking for help...

    Please read the search suggestion thread in JL Ideas

  12. #12
    Join Date
    Aug 2002
    Location
    Delaware
    Posts
    4,310
    Originally posted by mdwatts
    You will loose all your Linux filesystem permissions if you mount /home to a fat/fat32 partition and cause all sorts of problems as you've already noticed.

    Don't use fat/fat32 for a Linux filesystem.
    Well, the main technical reason is that you don't lose all your permissions (since the files wouldn't of had permissions to begin with. But that all fiels will have the exact same permissions and user. This "might" work for a single user's home directory (but still, wouldn't recommend it). But for a multiuser system, this will fail as everything will be usign a user, group and permissions scheme as found in either the /etc/fstab options or in the mount command used to mount the partition.

    So... don't use vfat / fat32 as /home.
    irc.freenode.net #justlinux The Not So Official JL IRC Channel.
    Debian Apt-Get

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •