Modem Configuration Help


Results 1 to 4 of 4

Thread: Modem Configuration Help

  1. #1
    Join Date
    Jun 2004
    Posts
    3

    Question Modem Configuration Help

    Hi, I'll start this off by saying that I am a newbie to Linux and chose to dual boot SuSE 9.1 home edition on a separate hardrive on my Windows XP home machine. It's a Sony vaio P4 2.4 ghz w/ inboard modem, lan, and sound. I live in a rural area where high speed internet is not available and will probably not be available for a while. So I'm trying to configure the modem to dial up my university's isp. I go into Yast2 and then to modems and click to configure the modem that it finds, it appears to be the right one. After i select new isp on the next menu and enter all the required information I click finish and it proceeds to do its configuration thing, when it gets to smppd it stops (about 66% complete), I've left it on this all day with still no progress, i have to log out to get the computer to do anything else and when i log back in it shows the modem as being configured but it wont connect to the internet when i click on the kinternet thing it gives me an error with smppd. Any help would be greatly appreciated and sorry about the long post.

  2. #2
    Join Date
    Dec 1999
    Location
    Toronto
    Posts
    39,320
    I won't be much help as I've never setup a modem in Linux (all ethernet), but I'll try at least until another member with modem experience can offer assistance.

    What model modem do you have? I would say it's likely a winmodem of which you would need to verify SuSE 9.1 has provided the proper winmodem packages. Here's a listing of their packages of which you can look for winmodem related packages.

    http://www.suse.com/us/private/produ...index_all.html

    You can check to see if any of those packages are installed by using

    rpm -q packagename (without the version # and extension i.e. rpm -q samba)

    You can then list the contents of those installed packages with

    rpm -ql packagename

    and look for the included documentation. Viewing the documentation should tell you what winmodems that package version are currently supported.

    Now if you find your winmodem model is not supported by any of the packages included with SuSE 9.1, head over to www.linmodems.org to see what you can find. Searching G4L ( www.google.com/linux ) for the model may find you additional resources.
    SEARCH FIRST... ASK SECOND Read the JL 'Community Help Posting Guidelines' before posting in the forums.

    Precompiled Redhat NTFS Modules

    Linuxplanet Tutorials

    If Linux doesn't have the solution, you have the wrong problem. ... Please do not send me a PM asking for help...

    Please read the search suggestion thread in JL Ideas

  3. #3
    Join Date
    Nov 2002
    Location
    Cape Town
    Posts
    40
    mdwatts's reply is meatier than mine, but when I started out in Linux I couldn't get my modem to work at ALL. In the end, what sorted it out was pointing directly to the com port it uses (/dev/ttys0) rather than any modem device.
    But it does sound like you're using a winmodem.
    In case you're wondering, a winmodem is just a phone jack on a card - it lacks the clever bits that make up a modem, relying on Windows components do to the thinking.
    My 2c is, get a proper modem and try again.
    It is of course possible to get a winmodem working in Linux, but it's unpleasant.
    Have a look at www.linmodems.org.
    D

  4. #4
    Join Date
    Jun 2004
    Posts
    3
    Thanks for the quick and helpful responses. SuSE detects the modem but just hangs up on smppd, is this how a winmodem acts w/o the proper packages? or am i wasting my time trying to find drivers/packages for it? I've spent some time at linmodems.com and have run the modem identification utility there. Something came up at school and I havent had much extra time to mess more with it. I must say though that the fact that my modem, printer, nic, and apc dosent work is quickly turning me off to linux .
    Last edited by redsport02; 07-03-2004 at 10:21 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •