Cannot startup linux

Results 1 to 3 of 3

Thread: Cannot startup linux

  1. #1
    Join Date
    Apr 2004

    Cannot startup linux

    Oh boy..
    I screwed up this one..
    Can anyone help me before I lose it with this pc?

    I added a new hard drive to my pc the other day *hdb" and tried to delete 2 partitions from the original disk in Suse (9.2) as part of a reorganisation after I unmounted them in Suse..

    When I tried to reboot, I got nothing, no grub boot menu, just a black screen with "TAB shows several grub options"..

    To cut a long story short, I have run the SUSE repair utility from CD, which installed a new boot loader, and checked the rest of the system. The 2 partitions keep appearing as "missing from fstab", with an option to remount them on /data2 /data3 and so on, but other than that, nothing.
    When I tried to boot using the new grub loader though, I get an error that "the root file system is currently mounted read only" and then the option to log in as root to fix it. The suggested mount command does not work after rebooting though.

    Choosing windows from the grub menu does not work either as this doesnt get past the splash screen.

    I can get into where I am now using a knoppix disk I have, and can see that all my data is still there, but I can't even reinstall Suse at the moment as I get an error finding the package list when I try to run the installation. (maybe because the disk is read only?)

    I can see that my fstab file is as below (I think the PC would be out of the window by now if not for this knoppix)

    knoppix@ttyp1[etc]$ cat fstab
    /dev/hda7 / ext3 acl,user_xattr 1 1
    /dev/hdb2 /data ext3 acl,user_xattr 1 2
    /dev/hda6 swap swap pri=42 0 0
    devpts /dev/pts devpts mode=0620,gid=5 0 0
    proc /proc proc defaults 0 0
    usbfs /proc/bus/usb usbfs noauto 0 0
    sysfs /sys sysfs noauto 0 0
    /dev/dvdram /media/dvdram subfs fs=cdfss,unhide,ro,procuid,nosuid,nodev,exec,iocha rset=utf8 0 0
    /dev/fd0 /media/floppy subfs fs=floppyfss,procuid,nodev,nosuid,sync 0 0
    /dev/sda2 /media/ipod subfs fs=vfat,procuid,nodev,nosuid 0 0
    /dev/hdb1 /home ext3 acl,user_xattr 1 2
    /dev/hda6 /data2 ext3 defaults 1 1
    /dev/hda6 /data3 ext3 defaults 1 1
    /dev/hda6 /data4 ext3 defaults 1 1
    /dev/hda6 /data5 ext3 defaults 1 1
    /dev/hda6 /data6 ext3 defaults 1 1
    /dev/hda1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
    /dev/hda5 /data7 swap pri=42 0 0
    /dev/hda8 /winshare ext3 users,umask=000 0 0
    /dev/hda6 /data8 ext3 defaults 1 1
    /dev/hda6 /data9 ext3 defaults 1 1

    Alll the /data2 /data3 /data9 lines etc are the ones the YAST repair utility has added.

    Anyone got any suggestions, would be MUCH appreciated

  2. #2
    Join Date
    Apr 2005
    San Antonio, TX
    I may be confused, but I can't see why /dev/hda6 would be mounted eight times under eight different locations.

    I run SuSE 9.2 pro, so I'll stick my fstab in here just as a comparison. With any luck, it can help in rescuing yours. I'd say the first thing to figure out though is why hda6 is being mounted so many times. It looks like it's your swap drive, plus 7 other drives all on the same partition. I really love Yast2, but their auto-partitioning system really bites sometimes.

    1 /dev/hde3 / reiserfs acl,user_xattr 1 1
    2 /dev/hda2 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
    3 /dev/hde1 /windows/D ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
    4 /dev/hdf1 /windows/F ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
    5 /dev/hdf2 swap swap pri=42 0 0
    6 /dev/hde2 swap swap pri=42 0 0
    7 devpts /dev/pts devpts mode=0620,gid=5 0 0
    8 proc /proc proc defaults 0 0
    9 usbfs /proc/bus/usb usbfs noauto 0 0
    10 sysfs /sys sysfs noauto 0 0
    11 /dev/cdrecorder /media/cdrecorder subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=ut f8 0 0
    12 /dev/fd0 /media/floppy subfs fs=floppyfss,procuid,nodev,nosuid,sync 0 0

  3. #3
    Join Date
    Apr 2004
    Yea, I looked back at this with fresh eyes this morning and must admit that should have been the first point.
    I have managed to recover fstab to the way it should have been, and found that the windows side (on /dev/hda1) will actually boot, although after a painfully long wait in the splash screen.

    When I try to boot Suse though, I get dropped into the command line with the above error about root filesystem being mounted read-only.

    fsck reports now
    "bad magic number in superblock while trying to open /dev/hda7".

    I have a bad feeling about the whole thing..
    The only bright thing is that by using knoppix, I am able to back up all my data before destroying the whole machine and starting over.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts