a desperate cry for help


Results 1 to 4 of 4

Thread: a desperate cry for help

  1. #1
    Join Date
    Jul 2005
    Posts
    4

    a desperate cry for help

    About two weeks ago I cleaned out my computer and there was no os on the hard drive at the time. I successfully took apart and put back together all the parts after cleaning them (they had tons of dust). I was also getting more and more interested in finally using Linux. But I had way too many problems...

    Firstly I have wireless. I can only use distros that have (or can easily compile) ndiswrapper to get internet access. Getting wired is not an option, even though I would love to. I have both the worst wireless pci card in the world (Linksys WMP54g), and I recently bought the D-Link DWL-G122 USB adapter.

    Feather Linux 0.7.4, my favorite up till now, keeps crashing about 10 mins after I boot into it (even in command line mode), and it's not dependant on any certain app (like firefox). I have no idea if version 0.7.5 is any different.

    Mandrake 10.1 refuses to let me even login, even with the right password.

    Some distros like DSL 0.5, Knoppix pre-3.4, Gnoppix, SLAX livecd 4.2.0, SAM Linux 2005-2 beta or whatever WILL NOT EVEN BOOT, PERIOD!

    SLAX 5.0.5 must have had a bad burn or something, becuase it won't boot (for a different reason though). If it is known to be a good distro I may try it again.

    And then there are distros so cruel not only do they not have ndiswrapper, they don't have tools like gcc and make to compile the source package I have (DSL 0.8.1)

    Some necessary source packages just won't compile no matter what. LFS LiveCD didn't have ndiswrapper, net-tools, or wireless-tools. I got the source, but only ndiswrapper compiled without errors (even though I read the instructions carefully to compile).

    Although Gentoo sounds great, it doesn't have ndiswrapper (to my knowledge). I would have to jump through way too many hoops.

    Don't suggest RedHat variants either, I have been molested in the past by it too.

    Mepis throws errors at my pretty good USB adapter, so the only way I'm online now is using the old card in a 2004 Mepis edition (with all the KDE bloat too).

    Slackware 8.1 won't let me startx. This was a couple of years ago so I don't remember which error.

    Now here's what I haven't tried:

    Feather Linux 0.7.5- I highly doubt anything much has changed since 0.7.4, being a minor increment.

    Ubuntu- Some like it, some don't, but I'm sick of apt-get not working for me (good non rpm/non dpkg apt-get deb distros would be great).

    Mepis 3.3- I think it still has some USB problems.

    Knoppix 3.9- Pure bloat, but if it works I'm willing to give it a try.

    Gnoppix (recent versions)- Does anyone who uses wireless have any experience with this.

    Zen- I don't have a DVD burner.

    Puppy- Does it have ndiswrapper? Not all these distros have package lists so it's pretty much a gamble.

    SUSE- I've heard tons of various kinds of problems other users have had with SUSE.

    Debian- Will anything be recent enough? Plus I don't want to have to burn 7 CDs.

    (anything)BSD- Sounds like great stuff, but its hardware support is even worse than in Linux.

    Astaro- Forget it, it costs money.

    Libranet- I think it costs money too.

    Macintosh G(whatver)- I'm not a noob, and I'm not loaded either.

    Aurox- Has ndiswrapper, and is a livecd, but I haven't tried it out yet.

    Slackware 10.1- It's worth a try, as long as things work.

    Windows XP- After taking apart my computer, my HP recovery cds don't work. It threw the error "these cd's don't support this model" even though put back everything the way it was. I really don't want to pay the $80 for another copy when I already paid for the OEM license. I was sorta forced to go into Linux (I had the interest and all, but not enough motivation) when this happened, and in this world things don't work for me.

    Windows 98 and such- My hardware is probably too new.

    Windows Server 2003- I don't know anything about it, but I have a friend who might buy an unlimited license, but he may charge me like $50 for it. It may not even work well with my hardware.



    So, right now, I would really like to get away from Debian based packaging, because it won't install software that I really want. Portage with Gentoo sounds great as long as the whole wireless thing can get resolved. Most likely I will try again with LFS LiveCD (either automated or manual install, although leaning towards automated because I've never compiled a kernel before).

    I would really like suggestions as for stable distros that don't give me any crap, and/or resolutions to the Gentoo wireless (or DSL wireless) "chicken-and-egg" dilemma.

    Thank you for any help.

  2. #2
    Join Date
    Mar 2005
    Location
    Singapore
    Posts
    246
    Um ... i think Gentoo has a ndiswrapper . Most distros i know ( and use frequently ) have to have internet acess before being able to use wireless. If you are going to gentoo , i suggest you d/load the documentation and the install + package cds . It might be able to work till you can get ndiswrapper up and get more ebuilds. Im not too sure though . Ask around the Gentoo Forums if you want a conclusive answer . There are many Gentooists here , so you coudl wait for a bit ill they post back .

    Good Luck with Linux ( Use it , Love it )

    Yours Sincerely

    xbaxe

    #98 +(5627)- [X]
    <ikkenai> i don't have hard drives. i just keep 30 chinese teenagers in my basement and force them to memorize numbers
    Courtesy of bash.org

  3. #3
    Join Date
    Jan 2003
    Location
    Zurich, Switzerland
    Posts
    2,658
    Well, since you haven't tried SuSE yet I still recommend trying it because in my past experience, SuSE is the nicest distro when it comes to hardware compatibility. However, it is true, sometimes SuSE throws a bug, too, and that can be harder to fix than in a less automated distro like Debian or Gentoo.

    So my suggestion is: try SuSE. If it doesn't work either, go for the distro you like best so far and try to solve the remaining problems you still encounter. Give us more background on the problems you run into, i.e. post error messages, log files, etc.

    Furthermore, please get used to starting new threads with a title that explains the problem in a few words, later users will be thankful for it - especially those using the search function. Additionally, please post one problem per thread, it will allow the discussion to be more focused and more helpful for you as a consequence. For further information please refer to the posting guidelines' link in my signature.

    "What can be said at all can be said clearly, and what we cannot talk about we must pass over in silence."

    Tractatus Logico-Philosophicus by Ludwig Wittgenstein (1889-1951)

  4. #4
    Join Date
    Jan 2003
    Posts
    1,012
    Since you haven't said what kind of box your trying to do this on (aside from the NIC) and going with some of the vague descriptions of what the OS's do while trying to install. I would have to say there are some hardware problems biting you.

    For example, Feather Linux crashing every ten minutes. That sounds like a possible memory problem but most likely some kind of heat issue.

    It's also quite possible something could have gotten damaged during the cleaning process. If there was that much dust and you used air to blow it out, it is conceiveable enough static electricity was created and popped something, particularly if add-in cards were removed to be cleaned.

    Regarding XP, perhaps any add-in cards were placed in different slots so it assumes new devices were installed.

    Some of you other descriptions sounds like damaged or bad checksums on the CDs.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •