How disable eth0 in red hat 9.0?


Results 1 to 7 of 7

Thread: How disable eth0 in red hat 9.0?

  1. #1
    Join Date
    Aug 2004
    Posts
    234

    Question How disable eth0 in red hat 9.0?

    Hi--

    I suspect my eth0 card got fried this week. I was using it for the in from the Internet side of a server which then served up files and the Internet to the other computers on the local network via its eth1 card.

    Now when I boot this Red Hat 9.0 machine, it sits and chugs away for a long time before it says it failed at bringing up interface eth0.

    Is there a way to fix it so that it does not even try to bring up this interface at bootup?

    Thanks!
    :-Doug.

  2. #2
    Join Date
    May 2003
    Location
    New Jersey
    Posts
    1,258
    I'm not entirely sure about how RH9 works anymore, but it looks like you can run this command
    Code:
    redhat-config-network
    and then it will allow you to add/remove/modify the network devices you have.

    If that doesn't work, you may just be able to disable having eth0 be configured on startup via the runlevels. Once again, though, I'm not exactly sure how this is done in RH9 anymore either.
    The Swain

    dswain

  3. #3
    Join Date
    Jan 2004
    Location
    Milwaukee
    Posts
    313
    There is a simple commandline fix as well - I never liked/trusted the Redhat network configurator. As I recall, the config file is /etc/sysconfig/network-scripts/ifcfg-eth0. To disable it at boot time, make the following change:
    Code:
    #ONBOOT=yes
    ONBOOT=no
    You can still try to bring up the adapter manually with
    Code:
    /sbin/ifup eth0
    In addition, /etc/modules.conf (renamed modprobe.conf in the Fedora Cores) contains an alias for the driver for your network adapter associated with eth0, something like
    Code:
    alias eth0 tg3
    Comment out that line if you don't want the driver to load ever.

    drChuck
    "Well, I've been to one world fair, a picnic, and a rodeo, and that's the stupidest thing I ever heard come over a set of earphones."

  4. #4
    Join Date
    Aug 2004
    Posts
    234

    Talking

    OK!

    Thank you, that looks like exactly what I needed!

    I will give it a try and see!

    Thanks to both of you!
    :-Doug.

  5. #5
    Join Date
    Aug 2004
    Posts
    234

    Question

    DSwain and DrChuck--

    OK, here is what happened. I do not have X even installed on this box, so could not use the configurator.

    All went well with changing ONBOOT to no, and on reboot it all seemed to mount OK; even /var/log/messages reported that eth1 had mounted (this is the other eth card, the one which serves up files to the local network). But I could not even ping this machine from the local network. When I did ifconfig eth1, then I could.

    So I reinstated ONBOOT=yes in /etc/sysconfig/network-scripts/ifcfg-eth0, and although on bootup "Bringing up eth0" fails, I can now ping (and open) files on this server.

    It seems to me like somehow the mounting of eth1 is dependent upon at least a try to mount eth0. Any idea what is going on and how to fix it?

    Thanks for your help, folks!
    :-Doug.

  6. #6
    Join Date
    Oct 2002
    Location
    Illinois
    Posts
    3,289
    if you believe that chip to have a real hardware problem, you might want to disable the device in the bios or remove it from the machine if possible

  7. #7
    Join Date
    Aug 2004
    Posts
    234

    Question

    dkeav--

    Thanks!

    Will disabling in bios allow the other one to mount without difficulty? I can't figure out why one would prevent the other....

    Thanks, dkeav!
    :-Doug.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •