System performance during periods of high hard disk activity


Results 1 to 11 of 11

Thread: System performance during periods of high hard disk activity

  1. #1
    Join Date
    Mar 2004
    Location
    /India/Mumbai
    Posts
    24

    System performance during periods of high hard disk activity

    Hi,
    I have gentoo (kernel 2.6.15-r7) on an AMD 64. My desktop becomes very unresponsive and almost unusable during periods of high hard disk activity. For example, while moving large files and ftp download at 2 MBps. I have been using linux for quite sometime and used to start a movie as it is getting downloaded. I cant even imagine running mplayer now. Even the mouse-movements become so patchy that its is almost impossible to use the computer while heavy downloads/ file movements are going on.

    Where can the problem be? I've googled but could find a solution to this.

    --Weshall

  2. #2
    Join Date
    Oct 2002
    Location
    Republic of Texas
    Posts
    5,908
    a couple of things come to mind...
    for your kernel, what are your timer settings?
    Code:
    Processor type and features  --->
    Timer frequency (250 HZ)  --->
    and also, what sceduler?
    Code:
    Block layer  --->
    IO Schedulers  --->
    <*> Anticipatory I/O scheduler
    <*> Deadline I/O scheduler
    <*> CFQ I/O scheduler 
    Default I/O scheduler (Anticipatory)  --->
    Those settings are from my 2.6.15-gentoo-r7 Configuration
    Need help in realtime? Visit us at #linuxnewbie on irc.libera.chat

    Few of us will do as much for our fellow man as he has done.
    --Andrew Morton on RMS

  3. #3
    Join Date
    May 2003
    Location
    New Jersey
    Posts
    1,258
    I find sometimes I get some real poor performance (or used to) before I correctly configured my kernel, somewhat like je_fro said above. In particular, I fixed my issues like that by checking the following part of the kernel config (making sure they're built into the kernel):
    Code:
    General Setup ----->
    	[*] System V IPC
    	[*] POSIX Message Queues
    	[ ] BSD Process Accounting
    	[*] Sysctl support
    Now, I don't really know if this will help with IO on a hard disk, but I found back a while ago when I first started building kernels that I would have similar symptoms. Basically, my machine would slow down to the point of being completely unusable. Not only would X stop responding, but also music couldn't play in the background and things like that. I found making sure these things were set like this really managed to get it working well.
    Last edited by DSwain; 04-29-2006 at 07:11 PM.
    The Swain

    dswain

  4. #4
    Join Date
    Mar 2004
    Location
    /India/Mumbai
    Posts
    24
    Thanks for the reply. Here's my kernel configuration ..

    Code:
     Timer frequency (250 HZ)  --->
     ( ) 100 HZ
     (X) 250 HZ
     ( ) 1000 HZ
    and my IO scheduler options are similar to je_fro's, default I/O scheduler being set to 'Anticipatory'. The 3 three options suggested my DSwain are also built into the kernel. I have this problem in spite of that ...

    --
    Weshall

  5. #5
    Join Date
    Jan 2003
    Posts
    979
    weird. you have dma enabled? (hdparm /dev/hda)

    i also got that slowness once, but only when i ran out of swap

  6. #6
    Join Date
    Mar 2004
    Location
    /India/Mumbai
    Posts
    24
    oh yeah ... DMA it is. DMA is not enabled and I am not able to do so .... I shall recompile the kernel will DMA support when this computer is free and get back to you guys.

    Thanks for the help...

  7. #7
    Join Date
    Feb 2003
    Location
    Mauritius
    Posts
    1,151
    you can enable DMA from hdparm, you should also enable 32bit mode, another suggestion would be to make sure that you have 32bit access enabled in the BIOS as well s set your HD to LBA mode...
    Feel free to PM me for help

    Using PCLinuxos 2007 on my laptop and 2009 on my Desktop and proud of it!

    Desktop:
    AMD Phenom II x2 545 3GB DDR2 RAM 500GB SATA,250GB SATA, 250GB IDE, ATI Radeon HD 4870 512 DDR3
    Laptop:
    Intel Core 2 Duo T7500 (2.2) 2GB RAM, 160GB Sata HDD, nVidia 8600GM 512MB

    Please come back and tell us if your problem is solved, it may help others, and stop us from wondering what happened.

  8. #8
    Join Date
    Aug 2001
    Location
    Somewhere, Texas
    Posts
    9,628
    DMA should be configurable without having to recompile. With Gentoo edit the /etc/conf.d/hdparm to include the drive and run rc-update putting hdparm in the boot. I'm using all_args="-d1"

    The kernel will need to be rebuilt to enable DMA on removable drives like CD/DVD drives.

    But before adding it, use hdparm to make sure it does work

    hdparm -d1 /dev/hda

  9. #9
    Join Date
    Jan 2003
    Posts
    979
    sometimes it wont work until you enable the support for your hardware in the kernel, it happened to me once. told me "operating not permitted"

  10. #10
    Join Date
    Aug 2001
    Location
    Somewhere, Texas
    Posts
    9,628
    Quote Originally Posted by rocketpcguy
    sometimes it wont work until you enable the support for your hardware in the kernel, it happened to me once. told me "operating not permitted"
    doh, that's right, I've been adding my custom hardware in the kernel for so long I forgot what the defaults were

  11. #11
    Join Date
    Mar 2004
    Location
    /India/Mumbai
    Posts
    24
    After the "Operation not permiited" errors, I recompiled my kernel. Built support for my driver (VIA82CXXX) into the kernel. DMA & 32-bit I/O mode was then automatically enabled when I booted into the new kernel.

    This did solve the system performance problems. hdparm -tT /dev/hda now gives:

    Code:
    # hdparm -tT /dev/hda
    
    /dev/hda:
     Timing cached reads:   2244 MB in  2.00 seconds = 1121.93 MB/sec
     Timing buffered disk reads:  168 MB in  3.02 seconds =  55.55 MB/sec
    Thanks everbody for help ...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •