Dual head set up in PCLinuxOS


Page 1 of 2 12 LastLast
Results 1 to 15 of 17

Thread: Dual head set up in PCLinuxOS

  1. #1
    Join Date
    Sep 1999
    Location
    Santa Cruz, CA, USA
    Posts
    1,213

    Dual head set up in PCLinuxOS

    ATi Radeon 7000 64MB dual head 4X AGP video card.
    Monitor #1 Dell FP1908
    Monitor #2 Dell FP1900

    Now when I had OpenSuSE on the system dual head set up was a breeze. But I can't seem to figure out how to get it to work with PCLinuxOS. Some of the "help" I have located refers to using ATi proprietary drivers. no problem with that except I can't seem to find one that is for an older card like mine.

    I tried Ximera set-up and that didn't work either. Not sure what to do or how to do it.
    One by one the penguins steal my sanity...

    Vanpooling now...

  2. #2
    Join Date
    Sep 1999
    Location
    Santa Cruz, CA, USA
    Posts
    1,213

    Rubber baby buggy bumpers

    and up this post goes... still no ideas? I have tried what I can find on the net so far... and as usual none of it works.
    One by one the penguins steal my sanity...

    Vanpooling now...

  3. #3
    Join Date
    Sep 1999
    Location
    Santa Cruz, CA, USA
    Posts
    1,213

    Well here is what is going on with this issue...

    okay so I have dual monitors (well actually had them before BUT... there is that evil but again!) and even though I told xorg.conf NO on clone it still is!?

    Code:
    # File generated by XFdrake (rev 57713)
    
    # **********************************************************************
    # Refer to the xorg.conf man page for details about the format of
    # this file.
    # **********************************************************************
    
    Section "Files"
        # font server independent of the X server to render fonts.
        FontPath "unix/:-1"
        
        # minimal fonts to allow X to run without xfs
        FontPath "/usr/share/fonts/misc:unscaled"
    EndSection
    
    Section "Extensions"
        Option "Composite"
    EndSection
    
    Section "ServerFlags"
        #DontZap # disable <Crtl><Alt><BS> (server abort)
        #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
        AllowMouseOpenFail # allows the server to start up even if the mouse does not work
        Option "Xinerama" "true"
    EndSection
    
    Section "Module"
        Load "dbe" # Double-Buffering Extension
        Load "v4l" # Video for Linux
        Load "extmod"
        Load "type1"
        Load "freetype"
        Load "glx" # 3D layer
        Load "dri" # direct rendering
    EndSection
    
    Section "InputDevice"
        Identifier "Keyboard1"
        Driver "kbd"
        Option "XkbModel" "pc105"
        Option "XkbLayout" "us"
        Option "XkbOptions" "compose:rwin"
    EndSection
    
    Section "InputDevice"
        Identifier "Mouse1"
        Driver "mouse"
        Option "Protocol" "ExplorerPS/2"
        Option "Device" "/dev/mouse"
    EndSection
    
    Section "Monitor"
        Identifier "monitor0"
        VendorName "Plug'n Play"
        ModelName "DELL 1908FP"
        HorizSync 31-83
        VertRefresh 56-76
        
        # Monitor preferred modeline (60.0 Hz vsync, 64.0 kHz hsync, ratio 5/4)
        ModeLine "1280x1024" 108 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
        
        # TV fullscreen mode or DVD fullscreen output.
        # 768x576 @ 79 Hz, 50 kHz hsync
        ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
        
        # 768x576 @ 100 Hz, 61.6 kHz hsync
        ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
    EndSection
    
    Section "Monitor"
        Identifier "monitor1"
        VendorName "Plug'n Play"
        ModelName "DELL 1900FP"
        HorizSync 31-83
        VertRefresh 56-76
        
        # Monitor preferred modeline (60.0 Hz vsync, 64.0 kHz hsync, ratio 5/4)
        ModeLine "1280x1024" 108 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
        
        # TV fullscreen mode or DVD fullscreen output.
        # 768x576 @ 79 Hz, 50 kHz hsync
        ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
        
        # 768x576 @ 100 Hz, 61.6 kHz hsync
        ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
    EndSection
    
    Section "Device"
        Identifier "device0"
        VendorName "ATI Technologies Inc."
        BoardName "ATI Radeon"
        Driver "ati"
        Option "DPMS"
        Option "XaaNoOffscreenPixmaps" "1"
        Screen 0
    EndSection
    
    Section "Device"
        Identifier "device1"
        VendorName "ATI Technologies Inc."
        BoardName "ATI Radeon"
        Driver "ati"
        Option "DPMS"
        Option "XaaNoOffscreenPixmaps" "1"
        Screen 0
    EndSection
    
    Section "Screen"
        Identifier "screen0"
        Device "device0"
        Monitor "monitor0"
        DefaultColorDepth 24
        
        Subsection "Display"
            Depth 8
            Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
        
        Subsection "Display"
            Depth 15
            Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
        
        Subsection "Display"
            Depth 16
            Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
        
        Subsection "Display"
            Depth 24
            Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
    EndSection
    
    Section "Screen"
        Identifier "screen1"
        Device "device1"
        Monitor "monitor1"
        DefaultColorDepth 24
        
        Subsection "Display"
            Depth 8
            Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
        
        Subsection "Display"
            Depth 15
            Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
        
        Subsection "Display"
            Depth 16
            Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
        
        Subsection "Display"
            Depth 24
            Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
    EndSection
    
    Section "ServerLayout"
    #    Identifier "layout1"
        Identifier "Multihead layout"
    #    Screen "screen1"
        Screen 0 "screen0" LeftOf "screen1"
        Screen 1 "screen1" 0 0
        InputDevice "Keyboard1" "CoreKeyboard"
        InputDevice "Mouse1" "CorePointer"
        Option "Xinerama" "on"
        Option "Clone" "off"
    EndSection
    So above is my xorg.conf why isn't the dual head working the way I want, with the desktop being extra long instead of cloned?
    One by one the penguins steal my sanity...

    Vanpooling now...

  4. #4
    Join Date
    Apr 2001
    Location
    SF Bay Area, CA
    Posts
    14,947
    Does it work to change your ServerLayout section so it looks like this instead:

    Code:
    Section "ServerLayout"
    #    Identifier "layout1"
        Identifier "Multihead layout"
    #    Screen "screen1"
        Screen 0 "screen0"
        Screen 1 "screen1" rightOf "screen0"
        InputDevice "Keyboard1" "CoreKeyboard"
        InputDevice "Mouse1" "CorePointer"
        Option "Xinerama" "on"
        Option "Clone" "off"
    EndSection
    That way, you're not specifying the coordinates of any individual Screen (which I didn't think was supported anyway, though I don't know that for sure), plus you're only referring to "screen0" after it's been added to the ServerLayout. (It's possible that X was getting confused because the leftOf operator thingy was referring to a non-added screen.)

    It's also possible that X isn't using this config file; to double check that, look at the first few lines in the X log file. (Make sure the log file has the right modified-date, just to be sure it's the log file for the X server you're running.) X usually logs which config file it read at startup.

    Edit: Nope, wait a second, I think I see the problem. In the "device0" and "device1" Device sections, you're referring to Screen 0 (in both of them). Change the "device1" Device so it refers to Screen 1, and that might help.

  5. #5
    Join Date
    Sep 1999
    Location
    Santa Cruz, CA, USA
    Posts
    1,213

    I will give it a try when I get into the office tomorrow

    LOL good catch! LOL
    One by one the penguins steal my sanity...

    Vanpooling now...

  6. #6
    Join Date
    Sep 1999
    Location
    Santa Cruz, CA, USA
    Posts
    1,213

    Well that didn't work

    made the change you suggested and it didn't work, I still have clone monitors. Still looking for the solution.
    One by one the penguins steal my sanity...

    Vanpooling now...

  7. #7
    Join Date
    Apr 2001
    Location
    SF Bay Area, CA
    Posts
    14,947
    I assume you've tried both changes? I took the ServerLayout from my own config file (although I use the nvidia driver, not ati, and it's been a while since I used the second head, I did have two independent desktops using that ServerLayout), so if your ServerLayout is still the way it was before, then it may be worth trying it the other way.

    Also, it may be worth posting your new config file and your Xorg.0.log -- perhaps there's some message in there that explains why it's not doing dual-head properly?

  8. #8
    Join Date
    Sep 1999
    Location
    Santa Cruz, CA, USA
    Posts
    1,213

    It will have to wait till Monday

    when I get back to the office. I will post that info first thing in the morning.

    Thank You!
    One by one the penguins steal my sanity...

    Vanpooling now...

  9. #9
    Join Date
    Sep 1999
    Location
    Santa Cruz, CA, USA
    Posts
    1,213

    More fun with dual monitors!

    Code:
    # xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by failsafeDexconf, using
    # values from the debconf database and some overrides to use vesa mode.
    #
    # You should use dexconf or another such tool for creating a "real" xorg.conf
    # For example:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    Section "Files"
    EndSection
    
    Section "Extensions"
    	Option	"Composite"
    EndSection
    
    Section "ServerFlags"
    	Option	"Xinerama" "true"
    EndSection
    
    Section "Module"
    	Load		"dbe" # Double-Buffering Extensions
    	Load		"v4l" # Video for Linux
    	Load		"extmod"
    	Load		"type1"
    	Load		"freetype"
    	Load		"glx" # 3D Layer
    	Load		"GLcore"
    	Load		"dri" # Direct rendering
    EndSection
    
    Section "InputDevice"
    	Identifier	"Keyboard"
    	Driver		"kbd"
    	Option		"CoreKeyboard"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"us"
    EndSection
    
    Section "InputDevice"
    	Identifier		"Mouse1"
    	Driver		"mouse"
    	Option		"CorePointer"
    	Option		"Device"	"/dev/input/mice"
    	Option		"Protocol"	"ImPS/2"
    	Option		"ZAxisMapping"	"4 5"
    	Option		"Emulate3Buttons"	"true"
    EndSection
    
    Section "Device"
    	Identifier	"device0"
    	Boardname	"ATI Radeon"
    	Busid		"PCI:1:0:0"
    	Driver		"ati"
    	Vendorname	"ATI Technologies Inc."
    	Option		"DPMS"
    	Option		"XaaNoOffscreenPixmaps" "0"
    	Screen	0
    EndSection
    
    Section "Device"
    	Identifier	"device1"
    	Boardname	"ATI Radeon"
    	Busid		"PCI:1:0:0"
    	Driver		"ati"
    	Vendorname	"ATI Technologies Inc."
    	Option		"DPMS"
    	Option		"XaaNoOffscreenPixmaps" "1"
    	Screen	1
    EndSection
    
    Section "Monitor"
        Identifier "monitor0"
        VendorName "Plug'n Play"
        ModelName "DELL 1908FP"
        HorizSync 31-83
        VertRefresh 56-76
        
        # Monitor preferred modeline (60.0 Hz vsync, 64.0 kHz hsync, ratio 5/4)
        ModeLine "1280x1024" 108 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
        
        # TV fullscreen mode or DVD fullscreen output.
        # 768x576 @ 79 Hz, 50 kHz hsync
        ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
        
        # 768x576 @ 100 Hz, 61.6 kHz hsync
        ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
    EndSection
    
    Section "Monitor"
        Identifier "monitor1"
        VendorName "Plug'n Play"
        ModelName "DELL 1900FP"
        HorizSync 31-83
        VertRefresh 56-76
        
        # Monitor preferred modeline (60.0 Hz vsync, 64.0 kHz hsync, ratio 5/4)
        ModeLine "1280x1024" 108 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
        
        # TV fullscreen mode or DVD fullscreen output.
        # 768x576 @ 79 Hz, 50 kHz hsync
        ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
        
        # 768x576 @ 100 Hz, 61.6 kHz hsync
        ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
    EndSection
    
    Section "Screen"
        Identifier "screen0"
        Device "device0"
        Monitor "monitor0"
        DefaultColorDepth 24
        
        Subsection "Display"
            Depth 8
            Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
        
        Subsection "Display"
            Depth 15
            Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
        
        Subsection "Display"
            Depth 16
            Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
        
        Subsection "Display"
            Depth 24
            Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
    EndSection
    
    Section "Screen"
        Identifier "screen1"
        Device "device1"
        Monitor "monitor1"
        DefaultColorDepth 24
        
        Subsection "Display"
            Depth 8
            Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
        
        Subsection "Display"
            Depth 15
            Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
        
        Subsection "Display"
            Depth 16
            Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
        
        Subsection "Display"
            Depth 24
            Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
        EndSubsection
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Multihead Layout"
      	Screen 0 "screen0"
      	Screen 1 "screen1" rightOf "screen0"
    	Inputdevice	"Keyboard" "CoreKeyboard"
    	Inputdevice	"Mouse1" "Corepointer"
    	Options	"Xinerama" "on"
    	Option 	"Clone" "off"
    EndSection
    This is the xorg.conf in MintLinux. Although I have set it to show dual monitors with the Clone option off... it's not off. Also I can't seem to get the resolution below 800x600. Same systems specs as noted in the beginning of this thread. Works fine with OpenSuSE 10.3 but OpenSuSE 10.3 has performance issues on this system. Mint is flying along great no issues other than the video.

    Did I miss something in my configuration?
    One by one the penguins steal my sanity...

    Vanpooling now...

  10. #10
    Join Date
    Sep 1999
    Location
    Santa Cruz, CA, USA
    Posts
    1,213

    Another thing

    when I try to use the Envy driver installer... I get this

    Code:
    python pulse.py ati oldest
    You will have domestic happiness and faithful friends.
    root@faser:/usr/share/envy# python pulse.py ati oldest
    Envy - Version 0.9.8
    Ubuntu Gutsy 32bit
    ENVY ERROR: ATI's legacy driver does not support your operating system
    So now what?

    Also when I run lspci I get this...

    Code:
    01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE]
    So does that mean this card is not supported by any of the proprietary drivers? If not, then how is it OpenSuSE was able to get this work (hey... seeing a pattern here) and yet I can't get MintLinux to work? Did I foobar my xorg.conf? Or is it correct and I am missing a package maybe? Or I have all the packages and I edited my xorg.conf correctly and Mint is having issues because it can?
    Last edited by MkIII_Supra; 11-13-2007 at 08:00 PM. Reason: Add more details...
    One by one the penguins steal my sanity...

    Vanpooling now...

  11. #11
    Join Date
    Sep 1999
    Location
    Santa Cruz, CA, USA
    Posts
    1,213

    Okay... I am tossing out ideas now...

    So I am getting frustrated... again.

    Solution 1: Suffer through the agonizingly slow performance of OpenSuSE
    10.3 but enjoy dual head.

    PROS: Dual head works, system appears stable.
    CONS: Many applications perform slowly or not as designed. RealBasic is one that comes to mind. Very slow and many standard features don't work. Many system speed.

    Solution 2: Continue to expend precious work time attempting to get MintLinux to work with the graphics ATi card (read set the correct resolution AND have dual head performance).

    PROS: Applications are snappy and function as designed. Overall the system screams compared to OpenSuSE on the exact same hardware.
    CONS: Resolution will not go below 800x600 and I cannot get the dual monitors to function out of clone.

    Solution 3: Buy some cheapo PCI video card and pray I can correct the monitor issue that way.

    PROS: If it works, good, done no more issue in this department.
    CONS: If it doesn't work, I am out the $$$ and time... again!

    Solution 4: Purchase a new nVidia dual head graphics card such as this one...
    PROS: Could solve problems since I know nVidia has excellent support for Linux.
    CONS: The motherboard is a 4X capable AGP slot, I so far have only found AGP 8X cards, I assume they can down grade but not all of them are clear on that.

    Your opinions? Suggestions? I mean I have used an entire 8 hour day on this one issue. That's 8 hours of my bosses time trying to get something that SHOULD work with little effort to work and still no where near getting it done.
    One by one the penguins steal my sanity...

    Vanpooling now...

  12. #12
    Join Date
    Sep 2005
    Posts
    681

    this might help you

    check out my post on tripple head cards. I havnt had this setup in a while . I dont use it anymore because i have multi computers setup and need the monitors for other machines


    http://justlinux.com/forum/showthrea...t=tripple+head
    "Software is like sex: it's better when its free."
    -LINUS TORVALDS

  13. #13
    Join Date
    Sep 1999
    Location
    Santa Cruz, CA, USA
    Posts
    1,213

    Aaaaaaahhhhhhhrrrrrggggg!!!!

    Before I get to the xorg.conf nightmare, I now have ANOTHER issue. One far more critical than the dual head set up...

    I have a Windows share (uh, rather important one at that!) that worked fine in PCLinuxOS, OpenSuSE and the older version of MintLinux (the one that couldn't get past 800x600 resolution yesterday!). But I cannot access the share!

    When I use konsole I get this:

    Code:
    Faser: mount /UCSC/Z_Microsoft/Utilities/
    [mntent]: warning: no final newline at the end of /etc/fstab
    mount: block device \\128.114.9.28\d$ is write-protected, mounting read-only
    mount: cannot mount block device \\128.114.9.28\d$ read-only
    Faser:
    This is the fstab entry, the one that has worked with no problems till now (cleaned of course for sec reasons)

    Code:
    \\###.###.#.##\d$  /UCSC/Z_Microsoft/Utilities  cifs  user,password=**********,uid=1000,gid=1000,username=\\FACILITIES\faser  0  0
    Now two other Windows mounts are working fine, they are the machine right next to me in my office. But this mount I am having trouble with is on the network somewhere else.

    I have used dpkg to install webmin, but it won't work either. That is how I set the share up in the first place.

    Now for the dual monitor issue. I tried the last recommendation and it killed X. So I am back on my original xorg.conf.

    Original xorg.conf
    Code:
    # xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"CoreKeyboard"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"us"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    	Option		"Device"	"/dev/input/mice"
    	Option		"Protocol"	"ImPS/2"
    	Option		"ZAxisMapping"	"4 5"
    	Option		"Emulate3Buttons"	"true"
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"stylus"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"	"stylus"
    	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"eraser"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"	"eraser"
    	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"cursor"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"	"cursor"
    	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "Device"
    	Identifier	"ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE]"
    	Boardname	"ATI Radeon"
    	Busid		"PCI:1:0:0"
    	Driver		"ati"
    	Screen	0
    	Vendorname	"ATI"
    	Option		"MergedFB"	"off"
    EndSection
    
    Section "Monitor"
    	Identifier	"DELL 1908FP"
    	Vendorname	"Dell"
    	Modelname	"Dell 1908FP(Digital)"
    	Horizsync	30.0-81.0
    	Vertrefresh	56.0-76.0
      modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
      modeline  "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
      modeline  "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
      modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
      modeline  "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
      modeline  "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
      modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
      modeline  "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
      modeline  "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
      modeline  "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
      modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
      modeline  "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
      modeline  "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
      modeline  "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
      modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
      modeline  "1280x960@75" 129.86 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
      modeline  "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
      modeline  "1600x1200@65" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
      modeline  "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
    	Gamma	1.0
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Device		"ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE]"
    	Monitor		"DELL 1908FP"
    	Defaultdepth	24
    	SubSection "Display"
    		Depth	24
    		Virtual	1600	1200
    		Modes		"1024x768@75"	"1024x768@70"	"832x624@75"	"1024x768@60"	"800x600@60"	"1152x864@75"	"800x600@75"	"1280x1024@75"	"800x600@72"	"1280x960@60"	"800x600@56"	"1280x1024@60"	"640x480@75"	"1280x960@75"	"640x480@72"	"1400x1050@60"	"640x480@60"	"1600x1200@65"	"1600x1200@60"
    	EndSubSection
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
      screen 0 "Default Screen" 0 0
    	Inputdevice	"Generic Keyboard"
    	Inputdevice	"Configured Mouse"
    	
    	# Uncomment if you have a wacom tablet
    	#	InputDevice     "stylus"	"SendCoreEvents"
    	#	InputDevice     "cursor"	"SendCoreEvents"
    	#	InputDevice     "eraser"	"SendCoreEvents"
    EndSection
    Section "Module"
    	Load		"glx"
    	Load		"GLcore"
    	Load		"dri"
    	Load		"v4l"
    EndSection
    Section "ServerFlags"
    EndSection
    Modified xorg.conf that failed
    Code:
    # xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Generic Keyboard"
    	Driver		"kbd"
    	Option		"CoreKeyboard"
    	Option		"XkbRules"	"xorg"
    	Option		"XkbModel"	"pc105"
    	Option		"XkbLayout"	"us"
    EndSection
    
    Section "InputDevice"
    	Identifier	"Configured Mouse"
    	Driver		"mouse"
    	Option		"CorePointer"
    	Option		"Device"	"/dev/input/mice"
    	Option		"Protocol"	"ImPS/2"
    	Option		"ZAxisMapping"	"4 5"
    	Option		"Emulate3Buttons"	"true"
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"stylus"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"	"stylus"
    	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"eraser"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"	"eraser"
    	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    	Driver		"wacom"
    	Identifier	"cursor"
    	Option		"Device"	"/dev/input/wacom"
    	Option		"Type"	"cursor"
    	Option		"ForceDevice"	"ISDV4"# Tablet PC ONLY
    EndSection
    
    Section "Device"
    	Identifier	"ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE] head 1"
    	Boardname	"ATI Radeon"
    	Busid		"PCI:1:0:0"
    	Driver		"radeon"
    	Screen	0
    	Vendorname	"ATI"
    #	Option		"MergedFB"	"off"
    EndSection
    
    Section "Device"
    	Identifier	"ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE] head2"
    	Boardname	"ATI Radeon"
    	Busid		"PCI:1:0:0"
    	Driver		"radeon"
    	Screen	1
    	Vendorname	"ATI"
    #	Option		"MergedFB"	"off"
    EndSection
    
    Section "Monitor"
    	Identifier	"DELL 1908FP"
    	Vendorname	"Dell"
    	Modelname	"Dell 1908FP(Digital)"
    	Horizsync	30.0-81.0
    	Vertrefresh	56.0-76.0
      modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
      modeline  "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
      modeline  "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
      modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
      modeline  "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
      modeline  "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
      modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
      modeline  "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
      modeline  "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
      modeline  "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
      modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
      modeline  "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
      modeline  "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
      modeline  "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
      modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
      modeline  "1280x960@75" 129.86 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
      modeline  "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
      modeline  "1600x1200@65" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
      modeline  "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
    	Gamma	1.0
    EndSection
    
    Section "Monitor"
    	Identifier	"DELL 1900FP"
    	Vendorname	"Dell"
    	Modelname	"Dell 1900FP(Digital)"
    	Horizsync	30.0-81.0
    	Vertrefresh	56.0-76.0
      modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
      modeline  "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
      modeline  "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
      modeline  "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
      modeline  "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
      modeline  "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
      modeline  "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
      modeline  "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
      modeline  "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
      modeline  "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
      modeline  "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
      modeline  "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
      modeline  "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
      modeline  "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
      modeline  "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
      modeline  "1280x960@75" 129.86 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
      modeline  "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
      modeline  "1600x1200@65" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
      modeline  "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
    	Gamma	1.0
    EndSection
    
    Section "Screen"
    	Identifier	"L Screen"
    	Device		"ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE] head 1"
    	Monitor		"DELL 1908FP"
    	Defaultdepth	24
    	SubSection "Display"
    		Depth	24
    		Virtual	1600	1200
    		Modes		"1024x768@75"	"1024x768@70"	"832x624@75"	"1024x768@60"	"800x600@60"	"1152x864@75"	"800x600@75"	"1280x1024@75"	"800x600@72"	"1280x960@60"	"800x600@56"	"1280x1024@60"	"640x480@75"	"1280x960@75"	"640x480@72"	"1400x1050@60"	"640x480@60"	"1600x1200@65"	"1600x1200@60"
    	EndSubSection
    EndSection
    
    Section "Screen"
    	Identifier	"R Screen"
    	Device		"ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE] head 2"
    	Monitor		"DELL 1900FP"
    	Defaultdepth	24
    	SubSection "Display"
    		Depth	24
    		Virtual	1600	1200
    		Modes		"1024x768@75"	"1024x768@70"	"832x624@75"	"1024x768@60"	"800x600@60"	"1152x864@75"	"800x600@75"	"1280x1024@75"	"800x600@72"	"1280x960@60"	"800x600@56"	"1280x1024@60"	"640x480@75"	"1280x960@75"	"640x480@72"	"1400x1050@60"	"640x480@60"	"1600x1200@65"	"1600x1200@60"
    	EndSubSection
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
      	screen 0 "L Screen" 0 0
    	screen 1 "R Screen" RightOf "L Screen"
    	Inputdevice	"Generic Keyboard"
    	Inputdevice	"Configured Mouse"
    	
    	# Uncomment if you have a wacom tablet
    	#	InputDevice     "stylus"	"SendCoreEvents"
    	#	InputDevice     "cursor"	"SendCoreEvents"
    	#	InputDevice     "eraser"	"SendCoreEvents"
    	Option "Xinerama"
    
    EndSection
    
    Section "Module"
    	Load		"glx"
    	Load		"GLcore"
    	Load		"dri"
    	Load		"v4l"
    EndSection
    
    Section "ServerFlags"
    EndSection
    It seems that my problems are multiplying instead of diminishing. I can't seem to get consistent results let alone expected results.I have been at this since 0730 this morning, trying to resolve these issues. Of course there was an entire day yesterday, totally gone, only thing productive I got done... answered an e-mail and 2 phone calls.

    Sorry I am just a little more than pI$$ed off at the moment. Are ANY of you guys in the Santa Cruz area? If so, stop by the Fackler heat plant and see if you can get this to work! Obviously I can't.
    Last edited by MkIII_Supra; 11-14-2007 at 02:52 PM. Reason: more information...
    One by one the penguins steal my sanity...

    Vanpooling now...

  14. #14
    Join Date
    Jan 2008
    Posts
    2

    busid

    try changing the second devices busid to "PCI:1:0:1

  15. #15
    Join Date
    Sep 1999
    Location
    Santa Cruz, CA, USA
    Posts
    1,213
    I went back to OpenSuSE 10.3 and am dealing with it's idiosyncrasies. Thanks though.
    One by one the penguins steal my sanity...

    Vanpooling now...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •