ACPI support in kernel crashes hp pavillion

Results 1 to 3 of 3

Thread: ACPI support in kernel crashes hp pavillion

  1. #1
    Join Date
    Sep 2005

    ACPI support in kernel crashes hp pavillion

    I am trying to get ACPI support in my kernel . I am running gentoo AMD64 bit distro on my HP pavillion 6258se. I have 4 partitions

    /dev/sda1 /boot
    /dev/sda2 swap
    /dev/sda3 /

    and /dev/sda4 is for LVM2 .

    the problem i have is if i have APCI in kernel 2.6.22 or higher it boots and randomly freezes. i heard it a a problem with kapcid. does anyone know how i can get this to work. i would even go to an older kernel . what is weird if i run the live cd it runs fine and i no apci is enabled. i have to pass

    apci=off to grub which is annoying if i cant see my battery levels or any info

    i have no way to set anything in bios for apci .
    "Software is like sex: it's better when its free."

  2. #2
    Join Date
    Sep 2005
    after doing some reasearch with others using same laptop , they said to disable RTC in the kernel. why would real time clock be freezing the computer ? i do find it strange. i will probably setup ntp on the machine . here is one article

    Free Web Hosting | Web Hosting | Free Web Space | Web Hosting

    Gentoo Linux on a HP Pavilion dv6258SE
    System characteristics

    My laptop now features the following:
    Processor AMD Turion(tm) 64 X2 TL-56; 1.8GHz, 2x512KB L1 cache
    RAM memory 2GB
    Hard disk Sata 120 GB
    Optical drive DVD-Multi recorder with DVD+RW and LightScribe
    Display 15.4" WXGA 1280x800
    Graphics nVidia GeForce Go 6150
    Wireless controller Broadcom 4311 802.11b/g Wireless LAN, IRQ 19
    LAN controller nVidia nForce 269
    Sound nVidia High Definition Audio - Stereo microphones
    Webcam HP Pavilion Webcam - Ricoh 1810
    Linux distribution Gentoo 2006.1 with Portage dated Mar 17 / 07
    Windows Vista Home Premium

    Following the good experiences with Gentoo on my Presario laptop, I decided to use Gentoo on this new, sleek box.
    Disk partitions

    I designed the following partition table for the hard disk:
    Name Partition type Filesystem type Size (MB) Comment
    sda1 Primary NTFS 13000 A very small Vista partition
    sda2 Primary NTFS 7000 Recue Vista partition
    sda3 Primary Linux Swap 3000 Pretty big swap
    sda5 Logical Linux ext3 10000 Gentoo System
    sda6 Logical Linux ext3 40000 /home
    sda7 Logical Linux reiserfs 40000 /home2, portage

    The fstab file shows the following:
    # fs mountpoint type options dump pass
    /dev/sda5 / ext3 defaults 0 1
    /dev/sda3 none swap sw 0 0
    /dev/sda6 /home ext3 defaults 0 0
    /dev/sda7 /home2 reiserfs defaults 0 0
    /dev/sda1 /mnt/vista ntfs noauto,users,ro 0 0
    /dev/sda2 /mnt/rescue ntfs ro,noauto,owner 0 0
    none /proc proc defaults 0 0
    none /dev/shm tmpfs defaults 0 0
    /dev/sdb /media/usb auto noauto,users,rw 0 0
    /dev/sdb1 /media/usb1 auto noauto,users,rw 0 0
    /dev/sdb2 /media/usb2 auto noauto,users,rw 0 0
    /dev/mmcblk0p1 /media/sd vfat noauto,users,rw 0 0

    Certainly, you will find a fstab which will fit your taste. I chose to keep the music and videos in the Linux partitions.

    I followed closely the Gentoo Handbook, so there is not too much to say in this page, except that the graphical installation program worked very well. Here are some hacks and tweaks I had to use specifically for my Pavilion laptop. I am sure they will become unnecessary soon.
    The Linux kernel

    The Genkernel system, as indicated in the Handbook, is a tool which tries to autodetect the appropriate kernel configuration before compiling; I didn't make use of this tool. Instead, I compiled the kernel gentoo-sources with a manually provided configuration, which you can download here. Please email me if you get a working configuration with Genkernel. (Do not forget about the wireless system!). The kernel command line is as follows:

    kernel /boot/vmlinuz-2.6.19-gentoo-r5-auriga vga=791 root=/dev/sda5 quiet

    These configurations were chosen for the following reasons:

    * RTC modules were deactivated because they lock up the System
    * nVidia framebuffer devices are uncompatible with nVidia drivers

    Emerging packages

    I used the following make.conf. I only post the relevant lines as a reference; perhaps you will want to use a close configuration:

    # These settings were set by the catalyst build script that automatically built this stage
    # Please consult /etc/make.conf.example for a more detailed example
    # Customizations by Fabio Correa
    PORTDIR_OVERLAY="/home2/sys/portage /home2/sys/portage-xeffects/xeffects/trunk"
    CFLAGS="-march=athlon64 -O3 -pipe"
    USE="-3dfx 3dnow X Xaw3d a52 aac -aalib -accessibility -acl acpi -adabas -adns -afs -aim alsa -altivec ao -apache -apache2 -apm arts audiofile -avahi bash-completion bcmath -berkdb -bidi -bindist -birdstep -blas -bluetooth -bonobo -boundschecking bzip2 cairo -calendar -canna caps -cdb cddb cdinstall cdparanoia cdr -chasen -cjk -clamav -cracklib crypt cups curl curlwrappers -db2 -dba -dbase -dbm -dbmaker dbus -dbx -debug -dedicated dga dio -doc dri dts dv dvb dvd dvdr dvdread emacs -emacs-w3 -emboss -empress -empress-bcs encode -esd -esoob -ev6 -evo -examples exif expat fam -fastcgi fbcon ffmpeg fftw -filepro -firebird firefox flac fltk foomaticdb fortran -freetds -freewnn -frontbase ftp -gb -gcj gd -gd-external gdbm -geoip -ggi gif ginac glut gmp -gnome -gnustep gnutls -gphoto2 gpm -gps -graphviz gstreamer gtk gtk2 gtkhtml guile hal -hardened -hardenedphp -howl -hyperwave-api -ibm -icc -iconv -icq idn -ieee1394 -ifc imagemagick -imap imlib -informix -ingres -inifile -innodb -interbase -iodbc ipod ipv6 jabber jack java javascript jbig jikes -joystick jpeg jpeg2k -junit kde kdeenablefinal -kdehiddenvisibility -kdexdeltas -kerberos -krb4 -ladspa -lapack lash lcms -ldap -leim lesstif -libcaca -libedit -libg++ -libgda libnotify libsamplerate libwww lirc -lm_sensors -lua -m17n-lib mad -maildir -mailwrapper -matroska -matrox -mbox -mcal -mcve -memlimit mhash -migemo mikmod -milter mime mmap mmx mng -mnogosearch -mono motif -mozilla mp3 mpeg mpi mplayer -msession msn -msql -mssql mule multilib -musepack -musicbrainz mysql mysqli nas ncurses -neXt -netboot -netcdf -nis nls -nntp -nocd -nocxx nptl nsplugin -ocaml -oci8 odbc offensive -ofx ogg openal opengl -oracle7 -oracle osc -oscar -oss -ovrimos -pcmcia pcntl pcre pda pdf -perl -pfpro php plotutils png portaudio posix -postgres ppds -prelude -profile -pulseaudio -python -qdbm qt3 -qt4 quicktime -radius -rdesktop readline -recode -ruby -samba -sapdb -sasl -scanner sdl -seamonkey -session -sharedext sharedmem -shorten -simplexml -skey slang -slp -smartcard sndfile -snmp -soap sockets socks5 -solid -source sox speex spell -spl -sqlite -sqlite3 sse sse2 ssl startup-notification svg -svga -sybase -sybase-ct symlink sysvipc szip tcl -tcpd tetex theora threads tidy tiff tk -tokenizer truetype -uclibc unicode usb -v4l vcd -verbose -vhosts videos vim-syntax -voodoo3 vorbis wddx wifi win32codecs -wmf -wxwindows x264 xcomposite -xface xine xinerama -xinetd xml -xmlrpc xosd xpm xprint xsl xv xvid yahoo -yaz zlib"

    INPUT_DEVICES="keyboard mouse synaptics"
    VIDEO_CARDS="nvidia vesa"
    LCD_DEVICES="X xosd"

    #For KDE-i18n
    LINGUAS="en_GB de es"

    #source /home2/sys/portage/local/layman/make.conf

    After rebooting, I put the files package.use, package.keywords, and package.mask in /etc/portage. I emerged the following packages in order:

    * emerge --deep --newuse --update -pv portage gcc glibc binutils
    * emerge metalog
    * emerge -C coldplug
    * emerge --deep --newuse --update udev hal tetex xorg-x11 kde
    * emerge --deep --newuse --update `cat world.txt`

    After this, I uncommented the last line of make.conf as shown above, such that the xeffects overlay is active. After that, you can emerge Beryl using one of the two possibilities provided:

    * layman -f xeffects
    * cd /home2/sys/portage; mkdir -p portage-xeffects/xeffects; svn co svn://

    After choosing the second line, I emerged Beryl:

    emerge beryl

    When using Beryl, it is strongly encouraged to disable the "Sync to VBlank" checkbox. Not only performance is greatly improved, but the system will be more stable, too. You can switch the virtual terminal with more confidence.
    Configured Features
    Keyboard and Remote Control

    Configuring the keyboard and remote control could not be more simple, but could be a little more straightforward. Basically, the remote buttons trigger the corresponding keyboard controls. All you have to do to have them working under KDE is to enter to the Control Panel -> Regional & Accessibility -> Keyboard Layout, and in Keyboard Model you select A4Tech KB-21. Why? Actually, I decided to give every model a try, and I found that the special buttons (Player, Print) work on the first model I tried.

    This nVidia card only works with the last versions of nvidia-drivers. Be sure it is in your package.keywords file. It is not compatible with the nVidia framebuffer devices, as pointed out when emerging:

    Your kernel was configured to include rivafb support!

    The rivafb driver conflicts with the NVIDIA driver, please reconfigure your kernel and *disable* rivafb support, then try installing the NVIDIA kernel module again.

    *** Failed rivafb sanity check. Bailing out! ***

    make[1]: *** [rivafb-sanity-check] Error 1
    make[1]: *** Waiting for unfinished jobs....
    Your kernel was configured to include nvidiafb support!

    The nvidiafb driver conflicts with the NVIDIA driver, please reconfigure your kernel and *disable* nvidiafb support, then try installing the NVIDIA kernel module again.

    *** Failed nvidiafb sanity check. Bailing out! ***

    make[1]: *** [nvidiafb-sanity-check] Error 1
    make: *** [module] Error 2

    After correctly compiled, you can use my own version of xorg.conf or refer to nvidia-drivers documentation.

    The traditional sequence to switch monitor/display (Fn+f4) does not work. Maybe it needs a separate controller. It is the same with brightness controls.
    RTC lockup

    A strange thing was happening while I was emerging the first packages: the laptop suddenly froze, lots of times, and that was so hard a lockup that even the text cursor stopped working. I realized that it is a problem with the hardware clock (RTC).

    The hardware clock keeps track of time when your laptop is turned off, even without the battery/AC adaptor. On startup your OS reads the time from this clock; Linux then creates the system clock, which keeps track of time when Linux runs. When shutting down, optionally, the time in the system clock is written back to the hardware clock.

    The problem with this HP Pavilion is that the process of reading from/writing to the hardware clock poses the risk of freezing the system. I had no opportunity of finding out the causes, mostly because no kernel crash dumps can be written to screen/files in this hard lockup. Then I decided to deactivate both RTC subsystems in the Linux Kernel, as configured in the Kernel section. Then, How in the world is the system clock set to the right time??? Here is a quotation from the hwclock manpage:

    You should be aware of another way that the Hardware Clock is kept synchronized in some systems. The Linux kernel has a mode wherein it copies the System Time to the Hardware Clock every 11 minutes. This is a good mode to use when you are using something sophisticated like ntp to keep your System Time synchronized. (ntp is a way to keep your System Time synchronized either to a time server somewhere on the network or to a radio clock hooked up to your system. See RFC 1305).

    Then, use ntp to keep your system in time.
    Card Reader

    The card reader requires the modules sdhci and mmc_block to work properly. Load them at startup, adding them to /etc/modules.autoload.d/kernel-2.6.

    PowerNow is the AMD technology to save power. It is present in your Turion processor, and that enables you to scale the clock frequency down to 800MHz. To ease the use of PowerNow, you can unmask and emerge laptop-mode-tools.
    Windows Vista

    As told before, I assigned a small partition to Windows Vista. After partitioning the hard disk, I ran the HP Recovery utility, located in sda2. It installs Windows Vista, device drivers and several bonus programs. The small partition system will make you uninstall different packages according to your needs and contempt for Microsoft and everything it represents.

    At last! the webcam is working. Sam Revitch has promptly answered my requests for a driver. I tried it with XawTV and worked very well; the full support is included only with the most recent development version of r5u870.

    There is a lot of unfinished work with my laptop:

    * LightScribe with Linux
    * FireWire tests
    * To get the modem working (Who cares about the modem? If you could afford de laptop, certainly you can afford broadband)
    * Expansion Port 3... I don't even know what can I do with it...

    Use this information under your own risk. I am not liable for what you do with it.
    Linux counter Powered by Gentoo Linux Linux On Laptops TuxMobil - Linux on Laptops, Notebooks, PDAs and Mobile Phones
    Last updated by Fabio on March 17, 2007.
    "Software is like sex: it's better when its free."

  3. #3
    Join Date
    Sep 2005
    i seemed to solve problem. all i did is add frame buffer in kernel for vesa and it all works

    my system now boots and doesnt freeze and ACPI seems to work correctly. does anyone know why that would make it stable ??
    "Software is like sex: it's better when its free."

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts