Long story short, I can boot to Debian but not WinXP. Long story follows...

It's been about 4 days since I installed Debian amd64 Lenny and 4 days since I was able to boot to WinXP. I've spent most of that time crawling google looking for an answer to my problem. As such, I've provided what I think is all the information that someone would need to help me (if not, please ask). FYI, I'm very new to Linux but not to Microsoft/Windows.

First off, I have 1 SATA hard drive that has WinXP and Debian on it:
fdisk -l output:
Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x9ef8fc24

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1       97262   781256983+   7  HPFS/NTFS
/dev/sda2           97263       98169     7285477+  83  Linux
/dev/sda3           98170      121601   188217540    5  Extended
/dev/sda5           99077      121601   180932031   93  Amoeba
/dev/sda6           98170       99076     7285414+  82  Linux swap / Solaris

Partition table entries are not in disk order
GRUB appeared to install just fine and boots Debian with no problems whatsoever. The problem is when I go to boot WinXP, I get the following:
root (hd0,0)
  Filesystem type unknown, partition type 0x7
chainloader +1
The relevant portion of my menu.lst file is as follows:
title		Debian GNU/Linux, kernel 2.6.26-2-amd64
root		(hd0,1)
kernel		/boot/vmlinuz-2.6.26-2-amd64 root=/dev/sda2 ro quiet
initrd		/boot/initrd.img-2.6.26-2-amd64

title		Debian GNU/Linux, kernel 2.6.26-2-amd64 (single-user mode)
root		(hd0,1)
kernel		/boot/vmlinuz-2.6.26-2-amd64 root=/dev/sda2 ro single
initrd		/boot/initrd.img-2.6.26-2-amd64


# This is a divider, added to separate the menu items below from the Debian
# ones.
title		Other operating systems:

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title		Microsoft Windows XP Professional
root		(hd0,0)
chainloader	+1
Here's the output of the grub geometry (hd0) command:
geometry (hd0)
drive 0x80: C/H/S = 0/255/63, The number of sectors = 1953525168, /dev/sda
   Partition num: 0,  Filesystem type unknown, partition type 0x7
   Partition num: 1,  Filesystem type is ext2fs, partition type 0x83
   Partition num: 4,  Filesystem type unknown, partition type 0x93
   Partition num: 5,  Filesystem type unknown, partition type 0x82
I've tried switching root to rootnoverify with no success.

I've already tried running FIXMBR and FIXBOOT in the WinXP recovery console which completely FUBR'd everything. Wasn't able to boot XP or GRUB or Linux so I ended up reinstalling Linux to get the GRUB boot menu back.

I've also tried banging my head on the desk. No results as of yet

If anyone has any idea on how to get my system dual booting with XP and Debian I'd LOVE to hear them. I'm pretty much at my wits end.