How to give Centos drivers for Embedded SATA Raid controller on HP Proliant

Results 1 to 3 of 3

Thread: How to give Centos drivers for Embedded SATA Raid controller on HP Proliant

  1. #1
    Join Date
    Sep 2009

    How to give Centos drivers for Embedded SATA Raid controller on HP Proliant

    hey friends

    I forced my workplace to forgo windows and opt for linux for web and mail server. I'm setting up Centos 5.4 on it and I ran into a problem. The server machine is a HP Proliant DL120 G5 (quad core processor, 4GB Ram, two SATA drives, 150GB each attached to the hardware RAID Controller on board). RAID is enabled in the BIOS.

    Now, I pop in the Centos disk and go through the installation process. When I get to the stage where I partition my hard drive, it is showing one hard drive, not as traditional sda... but as mapper/ddf1_4035305a86......a354a45.
    So I looked around and figured that I need to give Centos the raid drivers. I downloaded it from:

    I follow the instructions and download the aarahci-1.4.17015-1.rhel5.i686.dd.gz file and unzipped it using gunzip. Then on another nix system, i do this:
    dd if=aarahci-1.4.17015-1.rhel5.i686.dd of=/dev/sdb bs=1440k Note that I am using a usb floppy drive, hence the sdb. After that, during centos setup, i type: linux updates dd
    It asks me where the driver is located. I tell it and the installation continues in the graphical mode. But I still get mapper/ddf1_4035305a86......a354a45 as my drive. I tried to continue to install centos on it. It was successfull but when i do a "df -h" it gives me /dev/mapper/ddf1_4035305a86......a354a45p1 as /boot
    /dev/mapper/ddf1_4035305a86......a354a45p2 as /
    /dev/mapper/ddf1_4035305a86......a354a45p3 as /var
    /dev/mapper/ddf1_4035305a86......a354a45p4 as /external
    /dev/mapper/ddf1_4035305a86......a354a45p5 as /swap
    /dev/mapper/ddf1_4035305a86......a354a45p6 as /home

    Well i know why it's giving these, because i set it up that way, but i was hoping it would somehow change to the normal /dev/sda, /dev/sdb. That means that the driver i provided did not work. I have another IBM server (5U) with raid scsi drive and it shows the usual /dev/sda. It also has hardware raid. So i know that there is something wrong with the /dev/mapper/ddf1_4035305a86......a354a45p1 format.

    First, is there any way that I can put the aarahci-1.4.17015-1.rhel5.i686.dd (floppy image) on a CD?. I really need to set this up with raid. I know i could simply disable raid in bios and then i would get two normal hard drives sda and sdb. But it has to be a raid setup. Any way to slipstream the driver into the centos dvd? The hp link i provided above, under installation instructions, there are some instructions titled "Important". But I couldn't get it to work. What do they achieve? Guys, any help will be greatly greatly appreciated. Please... I need to get this server up and running soon. I am still and newbie but I learn fast and took on this task, believing I could do it. I am sure with all your help, I will be able to do it. Thanks in advance.

  2. #2
    Join Date
    Apr 2001
    Nashville, TN
    Why does it matter so much what the drives are named? Once you mount them, you shouldn't really be fooling around with them much again, anyways.

    It looks like, since you're using mapper, that the Linux RAID subsystem might be recognizing the RAID array, and there's nothing to configure, really. I know on my machine, where I've got 4x1TB drives in a RAID5, my mount points all look like:


    or something or other. So long as the drives are being recognized, formatted and mounted properly, I don't see what the problem is. RAID drives are probably going to look different from regular SATA drives in /dev/, anyways.
    Registered Linux user #230403! Since March 2001! YAY.

    Try doing a forum search or a google search before asking a question. And please don't use HELP! in the topic of your post... it's so lame... Please don't PM me for help-- post a question in the forum instead.

  3. #3
    Join Date
    Apr 2003
    On board RAID solutions are typically thinly disguised software RAID masquerading as hardware RAID rather than real hardware RAID. It seems likely that this is the case for your HP server and the linux kernel sees it for what it is and treats it as such, and the IBM has true hardware RAID so just shows up as a normal drive.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts