Helping Roku connect to netgear wnr854t wired

Results 1 to 2 of 2

Thread: Helping Roku connect to netgear wnr854t wired

  1. #1
    Join Date
    Aug 2004

    Question Helping Roku connect to netgear wnr854t wired


    My set up:
    Roku digital video player n1050 (it does not look like the ones in the manuals I have found online, and there was no manual in the box--this only has the red, white and yellow jacks on the back, plus the places to plug in the ethernet and power cables; reset is on the bottom)

    Wired network
    Netgear wnr854t
    Router assigns ipaddresses to devices attached to it
    Production environment
    7 computers regularly access this network wired
    1 additional computer regularly accesses this network both wired and wireless
    I am posting this going through this router, so you can see it is working

    Power up Roku with ethernet connected
    In set up, I chose wired connection
    Roku finds the ethernet cable
    Roku cannot find the local network and stops
    Router can see the Roku box, and says it is attached as
    I can successfully ping the Roku box, but not ssh into it.
    I can telnet into the Roku box using telnet 8080, but I do not see anything I can do from there.

    Can you help me get this Roku box connected to my network, please?


    PS: I am guessing it might have something to do with port forwarding or port triggering, but I am about at the limit of my networking knowledge!
    Last edited by dgermann; 08-28-2010 at 02:07 PM.

  2. #2
    Join Date
    Aug 2004



    To report back how I got it working:

    Roku's site was not helpful, nor have I gotten any help from the community boards.

    I did get lots of help from the boards at

    What initially worked for me was to go to the router's control pages and see where the roku was showing up. From there in the router's control pages I set up a static route to the roku. That got it working. I thought fine.

    A couple days later Roku tech support finally answered my email and said that A. the thing to do was to reboot all three: cable modem, router, and roku; and B. there was no way to set up a static ip on the roku.

    I experimented and first disabled and then completely removed the static route. Still the roku works.

    Theory: when I set up the static route, the router goes through some magic process that takes about a minute. That might be the equivalent of rebooting the router. Someplace in all this I did reboot the cable modem. And of course I was constantly rebooting the roku.

    So I suspect their method worked--simply reboot everything.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts