Ubuntu 10.04 server cli resolution too small


Results 1 to 11 of 11

Thread: Ubuntu 10.04 server cli resolution too small

  1. #1
    Join Date
    Aug 2004
    Posts
    234

    Question Ubuntu 10.04 server cli resolution too small

    Hi--

    After installing Ubuntu 10.04 lts server, when I go to log in, the type on the screen is so small I almost need a magnifying glass!

    I have tried several changes in /etc/default/grub:

    uncommented line GRUB_GFXMODE=640x480
    GRUB_GFXPAYLOAD_LINUX=800x600x24
    GRUB_GFXPAYLOAD_LINUX=720x480x8

    After each one I ran update-grub and rebooted. None of them made any difference. I suspect I am barking up the wrong tree.

    How do I make this large enough to read without going blind?

    Thanks!
    :-Doug.

  2. #2
    Join Date
    Jul 2002
    Location
    Vladivostok, Russia
    Posts
    9,054
    Do you have a graphical desktop eg:X-windows or can you do this with command line only?
    "I was pulled over for speeding today. The officer said, "Don't you know
    the speed limit is 55 miles an hour?" And I said, "Yes, but I wasn't going
    to be out that long."

    How To Ask Questions The Smart Way
    COME VISIT ME IN RUSSIA NOW!!

  3. #3
    Join Date
    Aug 2004
    Posts
    234

    Question

    JohnT--

    CLI only. Thanks for helping me John!
    :-Doug.

  4. #4
    Join Date
    Oct 2002
    Location
    Earth
    Posts
    1,615
    I did a quick google search and the thing I saw was that you need to modify the file /boot/grub/menu.lst. However, I don't have a server version of linux running and my regular desktop versions of Ubuntu and Slackware don't have a /boot/grub/menu.lst file. Maybe you do have that on a server install ?? Dunno. Good luck.
    -------------
    Folding is Fun

    I thought I made a mistake once, but, of course, I was mistaken.

  5. #5
    Join Date
    Jan 2003
    Location
    Austin, Texas
    Posts
    683
    bs_texas is right -- you probably need to pass the vga option to your kernel definition in menu.lst. For more info see the following posts:

    http://ubuntuforums.org/showthread.php?t=258484

    http://ubuntuforums.org/showthread.php?t=227513
    "The author of that poem is either Homer or, if not Homer, somebody else of the same name."

  6. #6
    Join Date
    Aug 2004
    Posts
    234

    Question

    gamblor01--
    bs_texas--

    Thanks. I think you are seeing the issue. Unfortunately, those threads are for an older version of grub. The newer one (grub2) does not have a menu.lst file.

    Thanks, bs_texas and gamblor01!
    :-Doug.

  7. #7
    Join Date
    Jul 2002
    Location
    Vladivostok, Russia
    Posts
    9,054
    Try here......I think this is what your looking for.
    "I was pulled over for speeding today. The officer said, "Don't you know
    the speed limit is 55 miles an hour?" And I said, "Yes, but I wasn't going
    to be out that long."

    How To Ask Questions The Smart Way
    COME VISIT ME IN RUSSIA NOW!!

  8. #8
    Join Date
    Aug 2004
    Posts
    234

    Question

    JohnT--

    Thanks for finding that for me, John!

    No joy, so far, but some hints perhaps. Here's what I did:

    1. I added those lines to /etc/default/grub (changing the resolution to 800x600x24) and ran the command they specified. Still the type is tiny.

    2. I commented out the line with 800x600x24 and uncommented the line already in there calling for 640x480 and ran sudo update-grub. Still the type is tiny.

    3. I appended "915.modeset=0" without quotes to the end of the "GRUB_CMDLINE_LINUX_DEFAULT="quiet"" line. Upon running sudo update-grub got an error message.

    4. Re-edited to put a comma in front of 915.modeset=0; still got error message.

    5. Put in a second GRUB_CMDLINE_LINUX_DEFAULT= line and put in the 915.modeset=0 line here, and finally update-grub ran without complaint. When I rebooted, got a lot of error lines scrolling too fast to read--but in a larger type. (Yay!) But then it switched back to the tiny type. (Boo!)

    6. Tried commenting out the old GRUB_CMDLINE_LINUX_DEFAULT="quiet" line, but still got the scrolling larger type switching to tiny.

    7. Tried rebooting and holding down shift key so I could get the grub menu so I could run the "vbeinfo" to see if I just need to specify a different resolution, but got no grub menu.

    Any thoughts on what I can try next?

    Thanks for helping me, John!
    :-Doug.

  9. #9
    Join Date
    Aug 2004
    Posts
    234

    Smile

    JohnT and all--

    Here is what I did that seems to have worked; my remaining question is how to make sure it is kept after an update?

    I edited the line in /etc/default/grub that reads:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet"
    to read instead:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet 915.modeset=0 nomodeset"
    Then sudo update-grub, then reboot.

    Anybody know how to make this stick?

    Thanks for helping me!
    :-Doug.

  10. #10
    Join Date
    Jul 2002
    Location
    Vladivostok, Russia
    Posts
    9,054
    I would make a backup of this file to begin with until you find a permanent solution.

    The link says that
    The gfxpayload property will make sure the kernel keeps the resolution.
    So I would assume unless you update Grub and/or the kernel it should keep.

    Also from the link:
    Recall previous entry
    Grub2 can remember the last entry you booted from and use this as the default entry to boot from next time. This is useful if you have multiple kernels (i.e., the current Arch one and the LTS kernel as a fallback option) or operating systems. To do this, edit /etc/default/grub and change the setting of GRUB_DEFAULT:
    GRUB_DEFAULT=saved
    This ensures that grub will default to the saved entry. To enable saving the selected entry, add the following line to /etc/default/grub:
    GRUB_SAVEDEFAULT=true
    Remember to regenerate your configuration file.
    "I was pulled over for speeding today. The officer said, "Don't you know
    the speed limit is 55 miles an hour?" And I said, "Yes, but I wasn't going
    to be out that long."

    How To Ask Questions The Smart Way
    COME VISIT ME IN RUSSIA NOW!!

  11. #11
    Join Date
    Sep 2000
    Location
    N California
    Posts
    953
    To ensure that your customizations are kept each time grub updates you need to modify the scripts that control the creation process. The scripts are found in /etc/grub.d/

    http://grub.enbug.org/​Manual#head‐2...9f796d6ebc8787

    http://​ubuntuforums.​org/showthread.​*php?t=1195275

    In debian I modified "05_debian_theme" to set my splash and color scheme.
    Maybe adding your custom GRUB_GFXMODE line in the 40_custom script will help.

    I modified the "GRUB_TIMEOUT=" parameter in /etc/default/grub and it seems to be maintained during multiple kernel updates in which update update-grub is run.

    Good Luck.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •