Broken Yum

Results 1 to 2 of 2

Thread: Broken Yum

  1. #1
    Join Date
    Nov 2002
    in my house.

    Broken Yum

    Hi, I can't use Yum to install packages anymore. When I try to install a package, I get this error:
    Code: [Errno 14] HTTP Error 404: Not Found
    and I discovered the error to be that the variable %24releasever is not being expanded into "5" which is my version of centos and what the URL should be for it to work. So, I did some digging in yum.conf and found this to be the problem:
    which according to google, should be
    So I changed it to that, but now the error it prints is
    Code: [Errno 14] HTTP Error 404: Not Found
    It prints that error because the 5.2 should be 5 which I discovered by going to the page in my browser and seeing that 5 is the only folder. I tried going into the redhat-release file and changing the version number there to 5 but it still tries to use 5.2.

    How can I fix this? Thanks!!

    "The Linux philosophy is 'Laugh in the face of danger'. Oops. Wrong One. 'Do it yourself'. Yes, that's it." - Linus Torvalds

    Registered linux user # 296563

  2. #2
    Join Date
    Sep 1999
    Cambridge, UK
    distroverpkg points to a version provided by an installed RPM, not the file in /etc. If you do yum whatprovides redhat-release you will see where the 5.2 comes from.

    In any case the URL in your cutter repo should contain $releasever so it is expanded by yum, not %24releasever which would be passed to the web server verbatim. Try fixing that first. If it still doesn't work just whack 5 in there.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts