In a case of root=/dev/ram0 real_root=/dev/sda2
No filesystem could mount root, tried: ext3 ext2...
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)
http://imageplay.net/img/tya22288136/IMG0204A.jpg (real_root - real panic)

The case of omitting real_root and using just root=/dev/sda2
VFS: Mounted root (ext2 filesystem) readonly on device 8:2
http://imageplay.net/img/tya22288134/IMG0203A.jpg - after the last line hangs without panic (alt+sysrq+b helps)

List of all partitions (befor kernel panic string):
0800 62522712 sda driver: sd
0801 204800 sda1 00000000-........0
0802 53928280 sda2 0...............0
0803 8388608 sda3 0........0
panic.....
Pid: 1, comm: swapper/0 Not tainted 3.4.9-gentoo #7

But, firstly about my system (wgetpaste -c lspci)
http://bpaste.net/show/50707/
Code:
# lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] nee ATI RX780/RX790 Chipset Host Bridge
00:02.0 PCI bridge: Advanced Micro Devices [AMD] nee ATI RD790 PCI to PCI bridge (external gfx0 port A)
00:05.0 PCI bridge: Advanced Micro Devices [AMD] nee ATI RD790 PCI to PCI bridge (PCI express gpp port B)
00:06.0 PCI bridge: Advanced Micro Devices [AMD] nee ATI RD790 PCI to PCI bridge (PCI express gpp port C)
00:0a.0 PCI bridge: Advanced Micro Devices [AMD] nee ATI RD790 PCI to PCI bridge (PCI express gpp port F)
00:11.0 SATA controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode]
00:12.0 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:12.1 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0 USB OHCI1 Controller
00:12.2 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:13.0 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:13.1 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0 USB OHCI1 Controller
00:13.2 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:14.0 SMBus: Advanced Micro Devices [AMD] nee ATI SBx00 SMBus Controller (rev 3c)
00:14.1 IDE interface: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 IDE Controller
00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 LPC host controller
00:14.4 PCI bridge: Advanced Micro Devices [AMD] nee ATI SBx00 PCI to PCI Bridge
00:14.5 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Link Control
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 03)
02:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 8400 GS] (rev a2)
02:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)
03:00.0 SATA controller: Marvell Technology Group Ltd. 88SE9120 SATA 6Gb/s Controller (rev 12)
04:00.0 USB controller: Fresco Logic FL1000G USB 3.0 Host Controller (rev 01)
05:06.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 08)
http://bpaste.net/show/50727/
http://bpaste.net/show/50703/
http://bpaste.net/show/50705/
.config :
http://bpaste.net/show/50708/
grub.conf
http://bpaste.net/show/50709/
/etc/fstab (May it be wrong without /shm?)
http://bpaste.net/show/50710/
http://bpaste.net/show/50711/
http://bpaste.net/show/50721/
/etc/portage/make.conf
http://bpaste.net/show/50712/
dmesg (right after boot from installation usb)
http://bpaste.net/show/50726/

And in the hope of "Chapter 7", Linux Sea - my case could be some overlooked controller for my SSD Crucial M4 64. I need to clarify SSD is different with HDD in Kernel Setup? Or slightly.. mb AHCI+SATA+RAID is a must chain? As I have an AMD (asrock mb) I couldn't find where is my missed option PIIX (Intel PIIX or AMD analogy).
RAM and root file system support seem to be not very far from working system:
http://imgur.com/a/VSsHV

- genkernel failed in the save way (VFS). That's why i began my long path make && make_modules
I've done the kernel without initramfs[*] and 2 partitions in ext2 (/boot ,/ ) in order to lessen the possibility of fail (esp on SSD). I can't fild those two in kernel except for Marvell:
Code:
00:11.0 SATA controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode]
00:14.1 IDE interface: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 IDE Controller
03:00.0 SATA controller: Marvell Technology Group Ltd. 88SE9120 SATA 6Gb/s Controller (rev 12)
I have no HDD only SSD and bootable flash minimal x86_64. Is an "PIIX4 PATA/SATA support" approprietable to me?
Why bzImage is in arch/x86/boot/bzImage (x86_64 only links to x86). And what i'm doing - recompiling kernel again & again with replaceing with cp.


Based on Pappy Kernel Seeds. ((Thanks to all you.. to this forum, the art of not being rude to ppl. with creative environment))