Serious problem with dual NICS and redhat 6.2

Results 1 to 13 of 13

Thread: Serious problem with dual NICS and redhat 6.2

  1. #1
    SKoL Guest

    Serious problem with dual NICS and redhat 6.2

    Specific help is needed with a very serious and complex problem I have been having for about 2 months..

    Scinero : Say I have one NT server. Dual NICS. NIC1 - 3com 3C905B - IP address 207.x.x.x NIC2 - Linksys - IP address Say this NT server is a MS proxy 2.0 server. Been working fine the past year.

    Problem : I turned this machine into a redhat 6.2 box. Same NICS, same cat5 cables, same patch panel, etc. The first NIC with the live ip (207) works great, pings internally and internet sites. On the other hand, the SECOND NIC doesnt' work at all. It doesn't show errors on boot up. Yet when i "ifconfig" it isn't up. I "ifup eth1" and it says "Network unreachable"

    I have tried 20 different kinds of installs. I have tried different nics. I have tried different cat5, different ports on the switches/patch panels. I have tried everything. What is wrong? I know the Linksys cards work, because some of my other redhat servers (with one nic) have linksys cards. I do a "dmesg" and everything is on a different IRQ, so its not that. What I am doing wrong?? I have converted an ALL NT network (30+ servers) all to redhat 6.2 There are 3 Proxy servers I want to change then I'm done Please help! I'll be watching for responses incase anyone needs anymore information.

    ---=== SYSTEM RULES ===--
    1. Do not post crap
    2. Obey rule #1
    3. Only post stuff that rule #2 allows

  2. #2
    Calvin_1976 Guest
    Is it dhcp or a static ip? And do you have files /etc/sysconfig/network-scripts/ifcfg-eth0 and /etc/sysconfig/network-scripts/ifcfg-eth1 ?

  3. #3
    SKoL Guest
    All static IP's..

    And yes I have both files...they are all there and everything seems to be where it is supposed to.

  4. #4
    Calvin_1976 Guest
    Try bringing the second ip up manualy with ifconfig

  5. #5
    SKoL Guest
    You mean like I said I had before? with ifup eth1?

    Doesn't work.

    "Network Unreachable" - it doesnt' make any F#*$#($ING sense, because the NT server had the same cables , nics etc and was working fine on both networks.

  6. #6
    Calvin_1976 Guest
    Like this
    ifconfig eth1 up
    then ifconfig and see if its there

  7. #7
    knute Guest
    Is linux seeing your second nic?

    If it is pci a simple "cat /proc/pci |less" will show it. (assuming that you are using PCI nics of course )

    Another thought -- Could they both be trying to use the same resources? If they are then only one will work at a time until one of them is changed...

    (If it is the nic's in conflict a simple way to test would be to bring down nic0 and try nic1, but then again that should also show up in the /proc/pci as well... )

    Hope it helps...

  8. #8
    SKoL Guest
    Yes, the card shows up and linux sees it. If there was a resource problem, wouldn't a dmesg tell me its on the same IRQ? *which it doesn't* And.......if it did have a resource problem, how would I go about fixing it.

    UGH! See, I've done this 100 times, at home *static DSL connection , redhat 6.2 routes all my household traffic* so its not like i'm a newbie....

  9. #9
    Sokertes Guest
    what happens if you take eth0 down then bring up eth1. does it come up. then try brining back up eth0. what happens?

  10. #10
    SKoL Guest
    I haven't tried that (at least I think i haven't) I'll try it tomorrow morn and see if it works..

    If anyone else has anymore ideas, thanks....

    And thanks to all who have reponded so quickly

  11. #11
    zGoRNz Guest
    dmesg | grep eth

    see what that shows if it doesn't show both eth0 and eth1 then you might need to modprobe

    try ifconfig -a
    this shows down interfaces too

    Dunt Dunt Duh...
    GoRN To The Rescue,
    Yet Again
    aim: GoRNToTheRescue

  12. #12
    syn Guest
    ps. are all the linksys cards the same kind?
    I mean I have linksys cards that work in 6.2 perfectly because they are version 2 cards, version 4 is out now and I bought one of those but havnt had the time to hunt down the drivers yet so it doesnt work yet, just an idea

  13. #13
    Join Date
    Jun 2013

    reverse path filtering on RHEL 6

    I believe this is due to the new reverse path filtering introduced in RHEL 6. It has changed how Redhat Linux do things a bit from Redhat 5. You can either Google "reverse path filtering" or just look at the following article to start:

    Hope that gets you into the right direction.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts