Desktop Time


Results 1 to 12 of 12

Thread: Desktop Time

  1. #1
    Join Date
    Feb 2014
    Posts
    9

    Desktop Time

    At time of Mint 16 installation I selected the correct time zone, but the desktop time if a few hours off. How can I correct this?

  2. #2
    Join Date
    Feb 2014
    Location
    Riviera Beach, Maryland, USA
    Posts
    155

  3. #3
    Join Date
    Feb 2014
    Posts
    9
    Thank you for the link.

    Unfortunately that did not solve my problem. The terminal command "sudo dpkg-reconfigure tzdata" allows to change the time zone, but the time zone does not match the local time (desktop time). There is a 6h offset. Likewise for the universal time.

    Hardware is Dell GX280. Any further suggestion?

  4. #4
    Join Date
    Feb 2014
    Location
    Riviera Beach, Maryland, USA
    Posts
    155

  5. #5
    Join Date
    Feb 2014
    Posts
    9
    Thank you again.

    The terminal command "date -s hh:mm:ss" corrected the time to match the timezone.

  6. #6
    Join Date
    Feb 2014
    Location
    Riviera Beach, Maryland, USA
    Posts
    155

  7. #7
    Join Date
    Feb 2014
    Posts
    9
    I've just discovered that there is a side effect to this method (or is it a bug?).

    The BIOS clock is modified incorrectly, it doesn't match the desktop time. As a result when I boot another drive in the same computer, with Windows XP, the time is displayed incorrectly with an offset of 6h.

    Any thought?
    Last edited by green-newbie; 03-23-2014 at 11:41 PM.

  8. #8
    Join Date
    Feb 2014
    Location
    Riviera Beach, Maryland, USA
    Posts
    155

  9. #9
    Join Date
    Feb 2014
    Posts
    9
    It's precisely how I discovered the anomaly. Setting up the CMOS/BIOS time to my local time and then booting up Mint 16 yields a desktop time 6h behind. Booting up Win XP yields the correct time, i.e. identical to the CMOS/BIOS time. In other words, no matter what I do with CMOS/BIOS or Mint 16 there is always that discrepancy. It looks very much like a bug to me.

    What do you think?

  10. #10
    Join Date
    Feb 2014
    Location
    Riviera Beach, Maryland, USA
    Posts
    155

  11. #11
    Join Date
    May 2002
    Posts
    1,251
    Not a bug.
    I assume the 6 hour offset is the difference between local and UTC. (aka GMT). Windows expects the BIOS/hardware clock to be local time but the default for linux is UTC. Its been awhile since I have played with mint so do not know if the date/time GUI has a checkbox to configure the hardware clock for UTC or local. The manual way for setting this is editing the following file and set
    /etc/default/rcS
    UTC=no

  12. #12
    Join Date
    Feb 2014
    Location
    Riviera Beach, Maryland, USA
    Posts
    155

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •