I didn't think that this could happen in Linux...

Results 1 to 14 of 14

Thread: I didn't think that this could happen in Linux...

  1. #1
    Join Date
    Jul 2002
    Bontang, East Kalimantan, Indonesia

    Angry I didn't think that this could happen in Linux...

    I've been running RH7.2 for about 8 months now on a dual-boot with WinME. I haven't had to use Windows for the last 4 months or so and don't ever intend on doing so. I've been using Gnome (haven't tried KDE yet). I last rebooted a couple of weeks ago when upgrading RAM to 512 mb. I have the following hardware:

    Pentium III 1.0 Ghz
    ASUS TUSL2-C motherboard
    512 MB Ram
    NVidia video card
    Soundblaster card
    etc, etc

    I normally run Nautilus, Opera 6, Mozilla 1.0, StarOffice5.2, Xmms and a few other programs all at the same time and performance has not sufferred exept that Gnome has been a little buggy where Nautilus refuses to load from time to time or suddenly disappears, whioh is only fixable by logging out and back in.

    The Problem:

    This morning I activated the sound feature under the Sawfish window manager just to see how it worked, which it did, for about 5 minutes. Suddenly, the whole system lockedup tighter than a drum. I waited about 5 minutes and then tried to get to a console with Ctrl-Alt-F2 but that didn't work. I then tried to kill X with Ctrl-Alt-Backspace but no dice and Ctrl-Alt-Del didn't work either so I rebooted with the power switch, ran fsck and fixed the damage and then disabled the sound in Sawfish. OK so far. Sound works, BTW for mp3 files so no problem there.

    My guess is this is a Gnome bug. Why does it freeze the system? I thought Linux was immune to the Windows-type freeze-ups.

    I am going to attempt to refresh my Gnome using the rpms on the RH cds. Should I do this without X running? I also have RH7.3. Would it be better to upgrade or just install the newer Gnome (and presumeably less buggy) from the RH7.3 cds?

    If I can't get to a terminal and Ctrl-Alt-Backspace doesn't work, is there an alternative to shutting down with the power switch?

    Thanks for any help or advice that anyone might have. Maybe others have had this problem too.

  2. #2
    Join Date
    Oct 2002
    My Red Hat Linux 8.0 system has frozen about 3 times now, where the only recourse is to push the system reset button.

    I don't recall exactly what causes it, but I'm sure it was something different each time. Unfortunately, each time I was in a hurry trying to do something so I didn't go back and try to figure out what happened and I don't really know my way around this system enough yet. Next time it happens I hope to go back and troubleshoot it.

    I don't have any MP3s or listen to music on this machine and I have a similar system to yours:
    P-III 866
    NVidia GeForce 3
    1024K memory
    etc etc

    And, my system is up2date also (except the kernel).
    rpm -q kernel
    Folding is Fun

    I thought I made a mistake once, but, of course, I was mistaken.

  3. #3
    Join Date
    Dec 2002
    UTC + 7
    Probably no Gnome, but eihter the enlightenment sound daemon or the module for the sound card. Before you go and star fixing things you should have a look at your system logs to see if there are any alerts about a problem. Also look at .xsession-errors in your home directory.

    If you haven't modified your system since you installed you might want to look at the www.redhat.com/errata for your system. Installing apt from http://freshrpms.net is probably trhe most painless way to upgrade. Consider switching to Alsa for sound.


  4. #4
    Join Date
    Dec 2002

    Lightbulb best solution if you have more than one machine

    Actually this is common if you are using beta software. (Usually fixed before mainline release) The fix is to ssh from another machine usuaally it is just easier to init 3 and then init 5 to get back and this doesn't cause the panic button to need to be pushed (but it does require a second machine) I have an old SuSE machine which I have had running for three years now that does this to me (why don't I fix it-well it still doesn't lock up on me as often as my win 98 box I installed 3 months ago )

    just enable ssh and ssh to the machine and do the init thing it works almost every time
    David Blomberg
    APS, CCNA, LCA, LCP, Linux+,
    RHCE, Server+

    Running Linux enhanced
    Computers how about you?

  5. #5
    Join Date
    Jul 2002
    I am using debian 3.0 and I have had one lockup type problem ever, and all it did was disable my usb mouse and I used the keyboard to restart. I mounted my digital camera via usb and then disconnected it without unmounting it. i think it took over my mouse, but it was my fault only.
    OS: Suse 9.1 Pro
    CPU: AMD Athlon XP 1700 (overclocked)
    GPU: Geforce 2 ti
    Soundcard: Soundblaster Audigy Gamer
    Ram: 512mb ram
    Mobo: LanParty NFIIULTRAB
    Storage: 2x 40mb IDE 1x80mb SATA
    Drives: HP dvd100i (dvd+RW/cdr/cdrw-writer)
    Case: Heavily modded Kingwin Aluminum
    CPU Cooling: Zalman Flower (fanless)

  6. #6
    GeekGuy Guest
    I'm using Debian 2.2 and I have had a few lockups - all were caused by X, never the OS.

  7. #7
    Join Date
    Jan 2001
    Gibsons, BC Canada

    Re: I didn't think that this could happen in Linux...

    Originally posted by louis_b

    If I can't get to a terminal and Ctrl-Alt-Backspace doesn't work, is there an alternative to shutting down with the power switch?
    Even if your mouse won't work in the app, it might work to open an x-term where you can reboot to take care of the actual problem.

    About a week ago, there was a thread re freeze-ups.

    Good luck!
    open mind, open source, open cars

    Registered Linux User 299372 http://counter.li.org

  8. #8
    Join Date
    Jul 2002
    Bontang, East Kalimantan, Indonesia
    Thanks to all for all of the quick responses.

    I just checked .xsessions-errors as suggested by adklgede and found many many messages of which the following is a repeat of an error message that Nautilus gives me when first starting up:

    Eel-WARNING **: GConf error:
    No database available to save your configuration:
    Unable to store a value at key '/apps/nautilus/sound_state', as the configuration server has no writeable databases. There are two common causes of this problem: 1) your configuration path file doesn't contain any databases or wasn't found or 2) OAF mistakenly created two gconfd processes. If you have two gconfd processes (or had two at the time the second was launched), then it's an OAF bug, not a GConf issue. Logging out, killing oafd and gconfd, and logging back in may help. As always, check the user.* syslog for details on problems gconfd encountered.

    I also checked and there is only one instance of gconfd running, so it's not an OAF bug.

    I also checked /etc/gconf/1/path which has the following:

    # This file stores the addresses of config sources for GConf
    # When a value is stored or requested, the sources are scanned from top to
    # bottom, and the first one to have a value for the key (or the first one
    # to be writeable) is used to load/store the data.

    # See the GConf manual for details

    # Look first in systemwide mandatory settings directory
    # (commented out until xml backend knows how to be read-only for users)

    # Now see where users want us to look - basically the user can stick arbitrary
    # sources in a ~/.gconf.path file and they're inserted here
    include "$(HOME)/.gconf.path"

    # Give users a default storage location, ~/.gconf


    # Finally, look at the systemwide defaults
    # (commented out for now)

    I do have a ~/.gconf directory but nowhere can I find a ~/.gconf.path file. Could the lack of this file cause the error and if so how do I re-create it?? I searched for the GConf manual with no luck and a Google search only pointed to where I could download GConf and Red Hat had nothing on the subject.

    I couldn't find any user.*syslog file to check but dmesg did tell me that the sound card ldriver loaded with no errors.

    Sorry for the length of this post...

  9. #9
    Join Date
    Dec 2002
    UTC + 7
    Since there was mention of the nautilous why don't you try turning off the blip boink and beep sound events in the file manager or in the GNOME control center.

  10. #10
    Join Date
    Nov 2002
    Long Island, NY
    All operating systems can freeze up. Some just do it less often as others. In total I've had to reboot my machine once in about 6 months now, so that isn't too bad.
    Linux User # 297035
    Linux: the choice of a GNU generation

  11. #11
    Join Date
    Jul 2002
    Bontang, East Kalimantan, Indonesia
    Originally posted by adikgede
    Since there was mention of the nautilous why don't you try turning off the blip boink and beep sound events in the file manager or in the GNOME control center.
    That's exactly what I did and no problems since. However, I would like to fix the underlying problem of GConf not being able to write to a database. I'm thinking of refreshing GConf using the GConf rpm on RH's CD but I don't know if that will fix the problem. I read somewhere that after installing GConf, ldconfig must be run. Will that create the necessary files in my home directory under .gconf? I'm hesitant to do anything yet because GConf seems to be fairly important, at least to Gnome and Nautilus and I don't want to break anything.

  12. #12
    Join Date
    Jan 2003
    sounds like your hardware is giving out. Try switching to a Dell precision workstation or the like.
    My redhat 8.0 never has a problem except for the bad rpm i try to --force on it now and then.

  13. #13
    Join Date
    Nov 2002
    Manchester, England
    the only reason my MDK9.0 system freezes is every time i try to load in invalid mod pack in Quake III Arena, which lock's out everything and leaves the mouse with a black screen. i aint complaining as it is a bug in quake 3, i just don't load the mods's via the mod menu (use the CLI) and it works fine

    my 2 pence
    () ()
    #justlinux on irc.freenode.net , your country needs you.

  14. #14
    Join Date
    Sep 2002
    Memphis in the meantime
    My SuSE crashed so hard, I had to reformat the drive... locked it up so tight fdisk couldn't read it, and I couldn't reboot. Oh well, it was time for Debian anyway. Now, my keyboard will intermittently stop responding , but I'm afraid this is a serious hardware problem, since my power source fan is making a horrible noise. My original harddrive just quit --- its an old box (5 years). Time for a new one
    Biscuits and Jam for all.
    "Never attribute to malice that which can be adequately explained by stupidity'': Hanlon's Razor

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts